Certificate for domain alias is not working properly

A week ago I setup my website and moved the DNS domain management from Domains.com to Netlify. Almost immediately the certificate for the primary domain started working correctly. But the alias *.mywebsite.com gives a warning that the site is not secure. I left it alone in case things would sort themselves out in time. A week later they haven’t.

So, I tried renewing the certificate and received the following error:
DnsApi::DnsError: rkellyraley.com - _acme-challenge.rkellyraley.com/TXT: 521 -
We can’t renew your Let’s Encrypt certificate automatically until the issue is resolved. Check our troubleshooting guide for more information on how to fix the problem, and then renew the certificate.

I tried the troubleshooting guide and tried submitting a support ticket before finding myself here.

Just got that fixed up for you, @kraley! Sorry not sure what caused it exactly (but my best informed guess is that DNS propagation for your NS record changeover hadn’t completed yet when you set it up initially), but I fixed it by pushing the button here: Netlify App

1 Like

Hi, I’ve just encountered the same error message, can’t make head or tail of it! What did you do to fix it?

Hi, @jamietwells, and welcome to our Netlify community site.

What Netlify site is this for? If you don’t want to public post the netlify.com subdomain, it is safe to send us the API ID here instead.

Oh, I only have the one site. Bit new to all this. It’s here:

Hi @jamietwells, not sure what the problem was, but clicking “Renew certificate” fixed it!