Can't disable Asset Optimization

I had enabled Asset Optimization for images recently to see if it would improve my pagespeeds. However, it seems that it has increased the TTFB for my images compared to how it was before. Now I’m trying to turn off the image optimization, but the change won’t apply.

I see in Netlify settings that images are not being optimized anymore. And I’ve redeployed and cleared the cache of the site. But images are still being served from the cloudfront cdn. TTFB is between 600ms-1000ms.

I just want to disable it…

Hi, @wpinfusion. Please make sure that optimization is completely disabled as shown in the following screenshot:

Once this is change, a new deploy will be needed for the images/assets to be moved off of Cloudfront.

If this doesn’t resolve the issue, please let us know.

Hi Luke, thanks for your reply. I’ve done this several times, but it won’t work.

Also, I notice that when I refresh my settings, the checkbox is not marked anymore (but neither are the items below it). This happens every time I try to disable Asset Optimization. I’ve also tried this in other browsers.

Thanks for confirming that behavior - I have gotten a bug filed and asked our team to look into it. We’ll follow up here as soon as things change.

For the moment I can reset that on your site in our database - which site(s) do you want that turned off on, please?

Hi fool,

Thanks for the feedback. I just got one site at https://ecstatic-tesla-6d772e.netlify.app/.

Thanks a lot

I had the same problem. The solution:

netlify.toml

[build.processing]
	skip_processing = true

OK, just got it disabled for you.

Hi,

We believe we have addressed this problem and you should be able to disable asset optimization from the UI again. Please let us know if you run into any issues. We apologize for the inconvenience.

Cheers,

Mike