Images via Cloudfront

I’ve got one img tag on the site, the other images are via CSS.

This one image when deployed on Netlify runs off a cloudfront domain, so it does a DNS lookup just for this imag.e Tthe CSS, JS, and all images referenced from them run off the main domain.

All the build processing stuff except pretty URLs are turned off.

Is there a way to stop this cloudfront url while retaining a normal image tag?

2 Likes

Having the same issue here also, but its all my files instead of images

I think we spoke to both of these in this other thread: CDN Change? Netlify CDN or Cloudfront

Asset optimization enabled at all == sometimes use cloudfront.

1 Like

@fool hi ! I have an annoying issue with this too : some images are served by cloudfront after I disabled image optimization. I only enable pretty urls and now i can’t get rid off urls like https://d33wubrfki0l68.cloudfront.net/93a0655578d837a4fb57648a5fa461a350fd8268/7b985/images/icon-linkedin.svg" for some icons. What can I do ? As images optimizations are explicitely disabled, this seems more like a bug : using only pretty urls should not involve any cloudfront interaction right ?

PS : if there are no solutions planned, please can you add a warning on this setting on the UI, as this is a unexpected behavior, and cause images to be blocked by adblockers because of that…

Hi, @nyl-auster, and welcome to the Netlify community site. :+1:

Would you please link us to the deploy at Netlify where that URL is being used? We’ll be able to research this further with that information.

Hello,

I face the same issue (cloudfront serves some images).

  • I read this thread and I can confirm that I have no asset optimisation. (i had before, but no more)
  • I disabled any cache plugin
  • I deploy with clear cache option.

But I still have some images served from cloudfront. So I think that @futuregerald sentence : “when you enable asset optimization of any kind, we’ll serve assets from Cloudfront.” has some exception.

And I’d like if possible to avoid generating absolute urls.

Any light ? (site is georgieff-osteo)

Hi, @divinerites, the post processing isn’t completely disabled for this site. All the sub-options are disabled but not the “top level” setting.

Please click the “Edit settings” button here and then check the box shown in this screenshot:

After changing that (and clicking “Save”), please trigger a new build and deploy of the site. If that doesn’t resolve the issue, please let us know

Thnaks. It works.

But this Interface is really tricky !
In tha same zone, Having all box unchecked and all not being disabled is not what you expect for a good UI.
Yes, it is writen “disable” for this box, but this is tricky.

May be having 2 zones for “disable all” and the rest would help UI wise.

Anyway, thanks a lot it solves the problem. And If i read the box more carefully I would have solved bu myself.

glad it’s working. we agree it could be more intuitive - hopefully we can get some changes to the UI at some point soon.