Cannot see Drawer on deploy preview

Congrats on shipping Collaborative Deploy Previews!

I wanted to try out the feature on a simple site, but cannot see the Netlify Drawer:

https://deploy-preview-1--xenodochial-liskov-849b91.netlify.app

Am I missing something?

Thanks!

Edit: My site repo is GitHub - anishkny/sample-netlify

Came here with the same question only to find this topic here already. So you’re not alone at least. :slight_smile: Looking forward to trying it out.

1 Like

Hi @anishkny and @simon

Thanks for reaching out, this is a great question!

If your index page or whatever the page is NOT an HTML file (e.g. just saying OK text) or invalid HTML file (e.g. without body tag), you won’t see the drawer. This is because we inject the drawer with the closing body tag, if the HTML file doesn’t have it, we can’t inject it.

That means, for example, the below code would not allow the drawer to be visible.

hello!
<br>
hi!

However, if you changed it to include body tags, it should work! For example:

<body>
helllo!
<br>
hi!
</body>

Let us know if this helps!

Thanks @hillary - that seems to have worked! https://deploy-preview-1--xenodochial-liskov-849b91.netlify.app

Perhaps this should be added to the documentation?

Cheers!

Hey there, @anishkny! So glad that worked for you. I will share your feedback with our team :slight_smile:

Hi @hillary, thanks for responding so quickly. It’s not working on my end unfortunately. I used an 11ty starter and its HTML output is valid. In addition there are no console errors. Any idea what’s going on over here?

https://deploy-preview-1--wizardly-shirley-a78cef.netlify.app

https://validator.w3.org/nu/?doc=https%3A%2F%2Fdeploy-preview-1--wizardly-shirley-a78cef.netlify.app%2F

Hey there @simon :wave:

Thanks for following up! I am happy to help here, and there are a couple other things may be happening that we can work through.

  1. Are you working with PRs that were created before Collaborative Deploy Previews were launched? If that is the case, I would suggest creating a new PR to see if that triggers the drawer.
  2. Are you using both GitHub as well as the Github App?

Let me know!

Same problem here. This preview is from a PR created this afternoon, and the snippet is being injected right before the closing body tag. However, the following warning from line 21 of netlify.js is in the console:

netlify.js: container not found.

Any ideas?

[Edited script line number]

  1. No, I created this PR today.
  2. Yes, GitHub and it’s Mac companion app, although the PR was made in github.com.

Thanks for your help! :slight_smile:

Thanks for those details, @simon and @polarweasel. I have looped in our team that built this feature and we will continue to work on this for you :slight_smile: hang tight!

1 Like

hey @polarweasel , thanks for working with us to get this figured out. We think we have it fixed, can you confirm you can see the drawer now?

@Perry YES it works now. Thank you!

Also, now there’s a warning from line 93 in the script about mismatched origins…

netlify.js: https://reflex.bigpicture.io does not match https://app.netlify.com.

glad it is working now! :star_struck: i passed the error you are seeing back to the team, and let you know if we have any updates.

another update - we pushed a fix for that odd error message. if you refresh the page, it should be gone. can you confirm?

Confirmed it’s gone @Perry. Thanks! Now I just need to figure out the whole permission thing, but this is looking great. :blush:

1 Like

fantastic! glad we got that worked out.

1 Like

@perry Did you manage to take a look at my preview deploy as well? I’m still not seeing it unfortunately. :slight_smile:

Hi there, @simon ,

Sorry for not following up yesterday evening! I have identified the issue and our Support Engineers are working on a fix for you. We will follow up on this thread when we have more information! Thanks for your patience :slight_smile:

HI @simon

Can you try installing the Github app and then attempting again? This is what I see when I look at your settings. Let us know once this is done :slight_smile:

Thanks @hillary, that gets me a bit further. I’m 100% positive though I got a dialog from Github asking me to confirm the additional rights Netlify was requesting. Perhaps something went wrong there.

I’m getting the icon now on the preview build, and when I expand it I get the option to either sign up or log in. I choose log in, and opt for logging in with my Netlify e-mail and password. However, then the Netlify app is opened in the pop-up window instead of enabling the sidebar/drawer. So I end up with this: