Cannot change DNS to Netlify

Hi, I get this error, while trying to change DNS to Netlify:

Update of name servers for domain failed: Command failed [53300102912 Nameserver error [ERROR: 118 Inconsistent set of NS RRs (NS, IP, NS host names) (, 2a00:edc0:6259:7:1::2, [‘’, ‘’, ‘’, ‘’]

Just so I understand you are trying to point your DNS to netlify? Is that what you mean?


“If your domain is registered with another provider, you can still take advantage of Netlify’s managed DNS service by delegating your domain to Netlify.”

Are you receiving this error when adding the domain to Netlify or when changing the nameservers with the domain registrar?

When changing the nameservers with the domain registrar,
if I try to change to netlify I get this error
If I change to digital ocean works fine

Netlify nameservers are showing (missing though) as are the digital ocean nameservers.

% dig NS		1800	IN	NS		1800	IN	NS		1800	IN	NS		1800	IN	NS		1800	IN	NS

If you want to use Netlify DNS, you’ll need to remove the Digital Ocean nameservers.

I must say I’ve never encountered this error before. I found a Server Fault post on this very topic though

Using the tool linked in that post, I see “Check successful”

If you are still having issues I would contact the registrar as they will have access to the account/domain whereas no-one here (including Netlify staff) will.

The ‘dig’ command displays the current status, as I have set DigitalOcean as the nameservers at the domain registrar. Later, in the DigitalOcean control panel, I attempted to add Netlify (it only succeeded for subdomains).

However, the issue is related to setting the nameservers at the domain registrar to directly point to Netlify. When trying to do this, an error occurs. Additionally, I have attached a screenshot for reference.

Try adding as well.

1 Like

thanks, I worked now, I don’t why, but worked

It probably worked because all 4 nameservers are required, no more, no less.

My first attempts to set up these servers yesterday involved providing 4 addresses to Netlify, and later I tried other variations like 2 or 3. But even when providing all 4, the error still occurred. In any case, the most important thing is that it works now.