Bundling of Edge Functions Suddenly Failing

Hi yall!

Is anyone else experiencing a failure to build edge functions on Netlify right now? We’re unable to deploy because Netlify can’t bundle our edge functions suddenly. Nothing with the edge functions has changed in days :thinking:

Here’s one of the deploys: Netlify App.

And here’s a screenshot:

It started failing between 10:14 and 10:34 am CST. I’ve tried redeploying the last good commit and that also fails, which makes me think it’s a Netlify issue.

I wonder; did you try the clear cache and redeploy?

I did, no luck. I’ve also tried renaming the edge function. I removed the edge function altogether and it deployed fine, and putting it back causes it to fail again.

1 Like

ok, Good job trying it out and doing the debug :grinning:

1 Like

On a side note, our engineers have informed us about this issue and they said, clearing cache should work.

I tried that already, but I can try again!

Well, we’ve let them know that you reported that this “fix” is not working. So, we’d be waiting for their comment on it. But till then, feel free to retry if you wish to.

1 Like

It worked this time! So whatever they did fixed it. Thanks @hrishikesh

Yeah, turns out they rolled a feature flag back. So the previous advice was moot. Glad to know it’s working.

1 Like