Build failure for VueJs

Hey Team,

These days I noticed build is failing for VueJs projects. I tried all possible solutions as following

  1. specifing the node version in the environment
  2. updating the build command to “CI: npm run build” and specifying a env variable as CI to false and tried deploying
  3. Updating netlify.toml file with the required build commands and publish directory

But none of them got worked. I tried even reaching to support team, but no reply.
Can you please suggest any solution?

Hi, I’m happy to suggest solutions, but it would be helpful if I could locate the site that is impacted. Mind sharing a site name?

Hey Sam,

Sure here is the site name that I just tried 30mins before

Please suggest me any solution

Hey Sam,

I see this vee-validate is creating an issue, but not sure how to resolve it as I tried the solutions that I came across and am aware of. Please check the below screen

Hope this helps to find the issue, please let me if you’ve any solution

Not sure if this would fix it, but you can try changing the build command to vue-tsc --noEmit --skipLibCheck.