Vue build keeps failing

(I need advice to debug deploy Netlify App)

so my app had been working ok.
but at some point, it suddenly started failing the build phase saying
12:27:05 PM: sh: 1: vue-cli-service: not found.

Tried many different approaches yet none of it worked.
I would really appreciate if anyone could help me solve this problem.

Your deploy log is private. Kindly make it public or post it here.

@machineric, I’m part of the Netlify support team so I can see the deploy (but no one else except you or someone with support level access to the team can).

It is possible to make the deploy public but don’t worry about that for now. @hrishikesh asked for it but, having examined the log myself, the line above is the only useful line in those logs.

This is npm/node complaining about a missing dependency. Would you please post your package.json file here?

I’m guess that this is happening because that package is in devDependencies (not dependencies) in package.json. You also have NODE_ENV set to “production” which excludes all the devDependencies. If this is the case, the solution is to a) move the dependency to dependencies or b) to stop setting NODE_ENV=production. Either/or (a or b) will work.

If there are other questions about this, please let us know.