Branch deploys updating both branch subdomain AND production site

Site name:
Custom domain:

My GitHub repository has 3 branches: master, preview, and v3.

Desired workflow: push changes to preview branch, wait for Netlify to build/deploy it, view in at, iterate as needed, then PR preview → master on GitHub, wait for Netlify build/deploy, and view it at

Actual behavior: Whatever I push to my preview branch becomes visible at both and

In Netlify Site Configuration, “Branches and deploy contexts” are configured like this:
Production branch: master
Branch deploys: preview, v3

I’m using Netlify DNS, and under Domain management > Branch subdomains, I’ve added preview and v3.

Any ideas why pushes to preview are showing up on my production site? I suspect it’s DNS related, because there doesn’t seem to be a delay in changes appearing in both places, and the Netlify console only shows 1 deploy (“Branch Deploy”).

Thanks in advance!

Could you please describe what should be different on the 2 URLs? Or in other words, what do you expect to show up on the main vs preview branch?

Thanks. Notice the text at the very top that reads “4.0 is here!” I’m about to push a change to PREVIEW that adds a hyperlink to that sentence.


I will reply again when that change is pushed/deployed.

Ok, that is done. Notice that “4.0 is here!” in the top banner is bold and hyperlinked on both sites:

I expect that it should only be bold/hyperlinked on preview, because the change was only pushed to the preview branch:

and not the master branch:

Thank you.

Looks like you’re using Split Testing: Build & deploy | Site configuration | flurl | Netlify, so that probably explains this.

1 Like

Ah, thank you! I’ll confirm with another deployment. Would you suggest I simply click “Stop test” to fix my issue? (Split testing isn’t something I’m using and I didn’t enable it on purpose.)

Simply stopping it should be enough. This setting doesn’t need a re-deploy.

Your’re a hero, thank you. Someday I might have to look at using the split testing feature (correctly) to improve my processes, but for now I’m back to where I wanted to be. Thanks again!