Blank page when deploying a react projec , no errors, build settings

That is my second time trying to start and deploy this project, and both times I get the same issue, but before I had errors being raised, now I only get a blank page, I have started using a create-react-app, and after its was ready and working well on localhost I have decided to deploy, I had some issues with broken Url and had fixed it with adding the Publish directory for my index.html on the deploy settings, I have also listed my homepage in my package.json, now, I have a blank page and the only thing that works is my headers (favicon, title, and etc…),
I have no idea what else I should try, it seems like the rest of my page it’s not being rendered

my link:https://baersilien.com/
on git hub://github.com/Rebecasa/barsilien](https://github.com/Rebecasa/barsilien)

That is my last Deploy Log:


Thank you,

1 Like

hi there, when you open the developer console, do you see any issues in your deployed page?

If yes, let us know.

@Rebecasa forked your repository and created a new site on Netlify. Everything worked as expected. You may have your settings setup incorrectly on the site.

Build command: yarn build
Publish directory: build

3 Likes

That works perfectly! Thank you so much, I was indeed using the wrong Publish directory.

2 Likes

Hello perry,

I have the same probleme in the developer console i see nothing :
repository git : https://github.com/azedine-lam/react-store.git
My site url :https://best-store.netlify.com/

can u plz help me.

thank you

hi @azedine.lamaouaj, welcome.

I have to disagree with you about not seeing errors - here are a bunch. Screenshot:

You’ll want to troubleshoot those - did you check to see whether they occur when you build your site locally?

Hello perry,

Thank you for ur quick reply , you are right , i disabled error log in my console that why i didn’t saw the error :frowning: its work now thank you very much

Le mar. 14 janv. 2020 à 01:56, Perry via Netlify Community netlify@discoursemail.com a écrit :

1 Like

glad it’s working now :slight_smile:

1 Like