Blank page deploying create-react-app

So I have successfully deployed the create-react-app and you can see with developer tools that it is using the /build/index.html file but for some reason it’s just a blank page, as if it’s not rendering anything. It works fine when I use npm run start from Vscode, but when I deploy it on Netlify it’s not rendering anything. I did not get any errors.

Hi @anolivemoonrises , welcome and thanks for the post.
Kindly share your build logs so that I can help with the debugging

Thanks.

1 Like

Hi @anolivemoonrises,

Thanks for reaching out and welcome to Netlify’s Support Forums!

If you fix the errors here:

Do you continue to have issues with builds?

Yes, after using the CL= fix I found in a different thread, it actually completely builds properly, but the issue is that the website is just a blank page. It correctly loads the html file as you can see in the developer tools, but it’s as if the javascript isn’t running at all, and thus nothing is being rendered.

Hi @anolivemoonrises,

Thanks for the follow-up.

I found this forum post while researching the issue you’re experiencing:

Could you go into your package.json and try removing the homepage line and see if that helps?

Wow, that actually worked thank you so much. I spent like 3 hours trying to get this app to deploy lol. Thank you.

Hi @anolivemoonrises,

Thanks for following up and letting us know that it worked. I hope you have a great day!