Azure - Failed during stage 'preparing repo': error checking for ref: fatal

SITE ID: marmallade

Git url on azure: Azure DevOps Services | Sign In

Build error: Failed during stage ‘preparing repo’: error checking for ref: fatal: ‘marmallade/Marmallade/_git/Marmallade.vendors_FE’ does not appear to be a git repository

In the account on Netlify I see “marmallade/Marmallade/_git/Marmallade.vendors_FE” for the repository URL but the correct URL of repository is: Azure DevOps Services | Sign In

But, in the account I can’t change this URL because the repo is on Azure and is not in Github/Gitlab or Bitbucket.

Could you change the URL for me?

Just incase it takes a while for a support engineer to view this, have you tried creating a new site and relinking the repo? Could be a one off issue if you’re lucky!

Yes, I tried!
With git config, I see the correct name for the repo.

hi! does that mean this is resolved? :thinking:

No, with git config the url of repo is correct but in Netlify I have the wrong URL.

ah, i see. ok, stay tuned, we will get you some assistance as soon as we can.

Hi, @crtdaniele. The method to link sites to Git repositories which are not hosted with a supported service (Bitbucket, GitLab, or GitHub).

There is more information about this in the following support guide:

The documentation for linking repositories with the Netlify CLI tool is found here:

If this solution doesn’t work for you or if there are other questions, please let us know.

1 Like

Hi @crtdaniele, it’s been awhile so you may not be hitting this issue anymore. However, I wanted to share that we recently released support for Azure DevOps as a Git provider. If you still have projects in Azure DevOps repos, that should make connecting them to Netlify more straightforward. Hope this helps and always happy to hear any feedback you may have!