All static routes without trailing slashes are being redirected

My site is at All of my routes are static pages (e.g. /this-is-not-a-google-font/index.html). For all links on my site, I would prefer to link to the path without trailing slashes (e.g. /this-is-not-a-google-font).

According to another post, netlify’s default behavior should be exactly what I want. However, all of my links are being redirected with a status of 301 to the same path with a trailing slash. I do not have Asset Optimization enabled, nor do I have a redirects file.


How can I fix all of these unwanted redirects?

That’s not how I read the linked post.

You’ve mentioned that your actual file location is:


It’s fairly subtle but that post effectively says:

/this-is-not-a-google-font.html -> /this-is-not-a-google-font
/this-is-not-a-google-font/index.html -> /this-is-not-a-google-font/

It’s outlined in this part:

1 Like

You are so right. I ended up just adding the slashes to all my links after I found yet another post that confirmed what you said. Thanks for your help!