Home
Support Forums

Wrong version of external dependency (GitHub) is being used

Update: Issue is that I did not use a version number with the library in the package.json. I think yarn is using the cached version of the library since the version or URL has not been changed.

Hi,

Just got a message from client and they noticed something off. I checked things and found that part of the production application is using development server.

We have a private repository of the shared code which we use as an external dependency in the package.json file of the app.

I have checked the dist folder of the shared repository and it has the correct URL. I tried installing the dependency and it installed with the correct URL.

Only on the Netlify, the build is using the wrong URL. Maybe an older version (when under development) of the library has been cached by the Netlify?

I have tried “Clear Cache and Deploy” but it did not work. Nor there is any error in the build stage.

Happy to provide URL in the message?

Some screenshots