Netlify missing latest yarn versions? Yarn 3.2.X

As a first check, my site builds perfectly on my machine.
I have the following:
Yarn: 3.2.3
Node: 14.20.0
Npm: 6.14.17
Site name: affectionate-goldwasser-33bf83

But on Netlify the latest version available is max 1.22.19.

FULL LOGG:

3:59:39 PM: Build ready to start
3:59:40 PM: ---------------------------------------------------------------------DEPRECATION NOTICE: Builds using the Xenial build image will fail after November 15th, 2022.The build image for this site uses Ubuntu 16.04 Xenial Xerus, which is no longer supported.All Netlify builds using the Xenial build image will begin failing in the week of November 15th, 2022.To avoid service disruption, please select a newer build image at the following link:https://app.netlify.com/sites/affectionate-goldwasser-33bf83/settings/deploys#build-image-selectionFor more details, visit the build image migration guide:https://answers.netlify.com/t/please-read-end-of-support-for-xenial-build-image-everything-you-need-to-know/68239---------------------------------------------------------------------
3:59:44 PM: build-image version: 1ac2360cf8aee6cb2695dd2682b312fefc908a7f (xenial)
3:59:44 PM: build-image tag: v3.15.0
3:59:44 PM: buildbot version: c87074660cd9a4568c0ac759bc083987e94204b3
3:59:44 PM: Building without cache
3:59:44 PM: Starting to prepare the repo for build
3:59:44 PM: No cached dependencies found. Cloning fresh repo
3:59:44 PM: git clone https://github.com/jassimahmed/blog2
3:59:45 PM: Preparing Git Reference refs/heads/master
3:59:45 PM: Parsing package.json dependencies
3:59:46 PM: ​❯ Initial build environmentbaseRelDir: truebranch: mastercontext: productioncwd: /opt/build/repofeatureFlags: []mode: buildbotrepositoryRoot: /opt/build/repositeId: 9bd6d0ee-f80a-4e34-9131-ec613edf6861​❯ UI build settingsbaseRelDir: truebuild:  command: yarn workspace minimal-blog build  environment:    - NETLIFY_BUILD_DEBUG    - NETLIFY_USE_YARN  publish: public​❯ Resolved build environmentbranch: masterbuildDir: /opt/build/repocontext: productionenv: []​❯ Resolved configbuild:  command: yarn workspace minimal-blog build  commandOrigin: ui  environment:    - NETLIFY_BUILD_DEBUG    - NETLIFY_USE_YARN  publish: /opt/build/repo/public  publishOrigin: ui
3:59:46 PM: Starting build script
3:59:46 PM: Installing dependencies
3:59:46 PM: Python version set to 2.7
3:59:47 PM: Downloading and installing node v16.17.1...
3:59:47 PM: Downloading https://nodejs.org/dist/v16.17.1/node-v16.17.1-linux-x64.tar.xz...
3:59:47 PM: Computing checksum with sha256sum
3:59:47 PM: Checksums matched!
3:59:50 PM: Now using node v16.17.1 (npm v8.15.0)
3:59:50 PM: Started restoring cached build plugins
3:59:50 PM: Finished restoring cached build plugins
3:59:50 PM: Attempting ruby version 2.7.2, read from environment
3:59:50 PM: Using ruby version 2.7.2
3:59:50 PM: Using PHP version 5.6
3:59:50 PM: Started restoring cached yarn cache
3:59:50 PM: Finished restoring cached yarn cache
3:59:51 PM: Found yarn version (1.22.10) that doesn't match expected (1.22.19)
3:59:51 PM: up to date, audited 1 package in 101ms
3:59:51 PM: found 0 vulnerabilities
3:59:51 PM: Installing yarn at version 1.22.19
3:59:51 PM: Installing Yarn!
3:59:51 PM: > Downloading tarball...
3:59:51 PM: [1/2]: https://yarnpkg.com/downloads/1.22.19/yarn-v1.22.19.tar.gz --> /tmp/yarn.tar.gz.5K6BMxlq5r
3:59:51 PM:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
3:59:51 PM:                                  Dload  Upload   Total   Spent    Left  Speed
3:59:51 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
3:59:51 PM: 100    81  100    81    0     0    408      0 --:--:-- --:--:-- --:--:--   407
3:59:51 PM: 100    81  100    81    0     0    408      0 --:--:-- --:--:-- --:--:--   407
3:59:52 PM: 100    95  100    95    0     0    232      0 --:--:-- --:--:-- --:--:--   232
3:59:52 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
3:59:52 PM: 100 1215k  100 1215k    0     0  1556k      0 --:--:-- --:--:-- --:--:-- 1556k
3:59:52 PM: [2/2]: https://yarnpkg.com/downloads/1.22.19/yarn-v1.22.19.tar.gz.asc --> /tmp/yarn.tar.gz.5K6BMxlq5r.asc
3:59:52 PM: 100    85  100    85    0     0   1250      0 --:--:-- --:--:-- --:--:--  1250
3:59:52 PM: 100    99  100    99    0     0    994      0 --:--:-- --:--:-- --:--:--   994
3:59:52 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
3:59:52 PM: 100   833  100   833    0     0   6065      0 --:--:-- --:--:-- --:--:--  6065
3:59:52 PM: > Verifying integrity...
3:59:52 PM: gpg: Signature made Tue 10 May 2022 07:48:23 PM UTC using RSA key ID 69475BAA
3:59:52 PM: gpg: Good signature from "Yarn Packaging <yarn@dan.cx>"
3:59:52 PM: gpg: WARNING: This key is not certified with a trusted signature!
3:59:52 PM: gpg:          There is no indication that the signature belongs to the owner.
3:59:52 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907  BBB7 1646 B01B 86E5 0310
3:59:52 PM:      Subkey fingerprint: 6D98 490C 6F1A CDDD 448E  4595 4F77 6793 6947 5BAA
3:59:52 PM: > GPG signature looks good
3:59:52 PM: > Extracting to ~/.yarn...
3:59:52 PM: > Adding to $PATH...
3:59:52 PM: > Successfully installed Yarn 1.22.19! Please open another terminal where the `yarn` command will now be available.
3:59:53 PM: yarn workspaces detected
3:59:53 PM: Installing NPM modules using Yarn version 1.22.19
3:59:53 PM: npm WARN config tmp This setting is no longer used.  npm stores temporary files in a special
3:59:53 PM: npm WARN config location in the cache, and they are managed by
3:59:53 PM: npm WARN config     [`cacache`](http://npm.im/cacache).
3:59:53 PM: yarn install v1.22.19
3:59:53 PM: warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
3:59:53 PM: [1/4] Resolving packages...
3:59:56 PM: warning netlify-cms-app > uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
3:59:57 PM: warning netlify-cms-app > netlify-cms-core > redux-devtools-extension@2.13.9: Package moved to @redux-devtools/extension.
3:59:58 PM: warning netlify-cms-app > netlify-cms-widget-markdown > slate-react > memoize-one@4.1.0: New custom equality api does not play well with all equality helpers. Please use v5.x
3:59:58 PM: warning netlify-cms-app > netlify-cms-core > url > querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
4:00:00 PM: warning netlify-cms-app > netlify-cms-widget-markdown > unified > @types/vfile > @types/vfile-message@2.0.0: This is a stub types definition. vfile-message provides its own type definitions, so you do not need this installed.
4:00:17 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-feed > @hapi/joi@15.1.1: Switch to 'npm install joi'
4:00:17 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-feed > @hapi/joi > @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
4:00:17 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-feed > @hapi/joi > @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
4:00:17 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-feed > @hapi/joi > @hapi/topo > @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
4:00:20 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-plugin-sharp > svgo > stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility
4:00:20 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-feed > @hapi/joi > @hapi/address@2.1.4: Moved to 'npm install @sideway/address'
4:00:20 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-feed > @hapi/joi > @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
4:00:23 PM: warning workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby > st > async-cache@1.1.0: No longer maintained. Use [lru-cache](http://npm.im/lru-cache) version 7.6 or higher, and provide an asynchronous `fetchMethod` option.
4:00:25 PM: [2/4] Fetching packages...
4:00:54 PM: warning geotiff@2.0.4: The engine "browsers" appears to be invalid.
4:00:54 PM: [3/4] Linking dependencies...
4:00:54 PM: warning " > gatsby-plugin-netlify-cms@6.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning " > gatsby-plugin-netlify-cms@6.24.0" has unmet peer dependency "react@^16.9.0 || ^17.0.0 || ^18.0.0 || ^0.0.0".
4:00:54 PM: warning " > gatsby-plugin-netlify-cms@6.24.0" has unmet peer dependency "react-dom@^16.9.0 || ^17.0.0 || ^18.0.0 || ^0.0.0".
4:00:54 PM: warning " > gatsby-plugin-netlify-cms@6.24.0" has unmet peer dependency "webpack@^5.0.0".
4:00:54 PM: warning "gatsby-plugin-netlify-cms > mini-css-extract-plugin@1.6.2" has unmet peer dependency "webpack@^4.4.0 || ^5.0.0".
4:00:54 PM: warning "gatsby-plugin-netlify-cms > html-webpack-plugin@5.5.0" has unmet peer dependency "webpack@^5.20.0".
4:00:54 PM: warning "gatsby-plugin-netlify-cms > copy-webpack-plugin@7.0.0" has unmet peer dependency "webpack@^5.1.0".
4:00:54 PM: warning "gatsby-plugin-netlify-cms > html-webpack-skip-assets-plugin@1.0.3" has unmet peer dependency "webpack@>=3.0.0".
4:00:54 PM: warning "gatsby-plugin-netlify-cms > html-webpack-tags-plugin@3.0.2" has unmet peer dependency "webpack@^5.0.0".
4:00:54 PM: warning "gatsby-plugin-netlify-cms > @soda/friendly-errors-webpack-plugin@1.8.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
4:00:54 PM: warning " > netlify-cms-app@2.15.72" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning " > netlify-cms-app@2.15.72" has unmet peer dependency "react-dom@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > @emotion/styled@10.3.0" has unmet peer dependency "react@>=16.3.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-azure@1.3.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > @emotion/core@10.3.1" has unmet peer dependency "react@>=16.3.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-bitbucket@2.14.0" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-git-gateway@2.13.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab@2.13.0" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-test@2.11.3" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-github@2.14.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-core@2.55.2" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-core@2.55.2" has unmet peer dependency "react-dom@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-core > ajv-keywords@5.1.0" has incorrect peer dependency "ajv@^8.8.2".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-editor-component-image@2.7.0" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-ui-default@2.15.5" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code@1.3.4" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-proxy@1.2.3" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-colorstring@1.1.2" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-datetime@2.7.4" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-date@2.6.3" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-date@2.6.3" has unmet peer dependency "react-dom@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-file@2.12.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-list@2.10.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-markdown@2.15.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-markdown@2.15.1" has unmet peer dependency "react-dom@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-map@1.5.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-object@2.7.2" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-number@2.5.0" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-relation@2.11.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-boolean@2.4.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-select@2.8.2" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-string@2.3.0" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-text@2.4.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-image@2.8.1" has unmet peer dependency "react@^16.8.4 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > @emotion/styled > @emotion/styled-base@10.3.0" has unmet peer dependency "react@>=16.3.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-cache-inmemory@1.6.6" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-client@2.6.10" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-link-http@1.5.17" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-ui-default > react-transition-group@4.4.5" has unmet peer dependency "react@>=16.6.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-ui-default > react-transition-group@4.4.5" has unmet peer dependency "react-dom@>=16.6.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-select@4.3.1" has unmet peer dependency "react@^16.8.0 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-select@4.3.1" has unmet peer dependency "react-dom@^16.8.0 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-ui-default > react-aria-menubutton@7.0.3" has unmet peer dependency "react@^16.3.0 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-colorstring > react-color@2.19.3" has unmet peer dependency "react@*".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-codemirror2@7.2.1" has unmet peer dependency "react@>=15.5 <=16.x".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-core > redux-notifications > react-redux@4.4.10" has incorrect peer dependency "redux@^2.0.0 || ^3.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-datetime > react-datetime@3.1.1" has unmet peer dependency "react@^16.5.0 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-ui-default > react-toggled@1.2.7" has unmet peer dependency "react@>=15".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-markdown > slate-react@0.22.10" has unmet peer dependency "react@>=16.6.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-markdown > slate-react@0.22.10" has unmet peer dependency "react-dom@>=16.6.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-text > react-textarea-autosize@8.3.4" has unmet peer dependency "react@^16.8.0 || ^17.0.0 || ^18.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-cache-inmemory > apollo-utilities@1.3.4" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-client > apollo-link@1.2.14" has unmet peer dependency "graphql@^0.11.3 || ^0.12.3 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-link-http > apollo-link-http-common@0.2.16" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-backend-gitlab > apollo-cache-inmemory > apollo-cache@1.3.5" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0 || ^15.0.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @emotion/react@11.10.4" has unmet peer dependency "react@>=16.8.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-select > react-input-autosize@3.0.0" has unmet peer dependency "react@^16.3.0 || ^17.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-colorstring > react-color > @icons/material@0.2.4" has unmet peer dependency "react@*".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-markdown > slate-react > slate-react-placeholder@0.2.9" has unmet peer dependency "react@>=16.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-text > react-textarea-autosize > use-composed-ref@1.3.0" has unmet peer dependency "react@^16.8.0 || ^17.0.0 || ^18.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-text > react-textarea-autosize > use-latest@1.2.1" has unmet peer dependency "react@^16.8.0 || ^17.0.0 || ^18.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-select > @emotion/react > @emotion/babel-plugin@11.10.2" has unmet peer dependency "@babel/core@^7.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-select > @emotion/react > @emotion/use-insertion-effect-with-fallbacks@1.0.0" has unmet peer dependency "react@>=16.8.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-text > react-textarea-autosize > use-latest > use-isomorphic-layout-effect@1.1.2" has unmet peer dependency "react@^16.8.0 || ^17.0.0 || ^18.0.0".
4:00:54 PM: warning "netlify-cms-app > netlify-cms-widget-code > react-select > @emotion/react > @emotion/babel-plugin > @babel/plugin-syntax-jsx@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
4:00:54 PM: warning " > @testing-library/react@13.4.0" has unmet peer dependency "react@^18.0.0".
4:00:54 PM: warning " > @testing-library/react@13.4.0" has unmet peer dependency "react-dom@^18.0.0".
4:00:54 PM: warning " > gatsby-cypress@2.24.0" has incorrect peer dependency "cypress@^3.1.0".
4:00:54 PM: warning " > gatsby-cypress@2.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning " > @lekoarts/gatsby-theme-minimal-blog-core@5.0.1" has unmet peer dependency "gatsby@^4.0.0".
4:00:54 PM: warning " > @lekoarts/gatsby-theme-minimal-blog-core@5.0.1" has unmet peer dependency "react@^18.0.0".
4:00:54 PM: warning " > @lekoarts/gatsby-theme-minimal-blog-core@5.0.1" has unmet peer dependency "react-dom@^18.0.0".
4:00:54 PM: warning " > @lekoarts/gatsby-theme-minimal-blog@5.0.1" has unmet peer dependency "gatsby@^4.0.0".
4:00:54 PM: warning " > @lekoarts/gatsby-theme-minimal-blog@5.0.1" has unmet peer dependency "react@^18.0.0".
4:00:54 PM: warning " > @lekoarts/gatsby-theme-minimal-blog@5.0.1" has unmet peer dependency "react-dom@^18.0.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-source-filesystem@4.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-remark-images@6.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-transformer-sharp@4.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-plugin-mdx@4.3.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-plugin-mdx@4.3.0" has unmet peer dependency "react@^16.9.0 || ^17.0.0 || ^18.0.0 || ^0.0.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-plugin-mdx@4.3.0" has unmet peer dependency "react-dom@^16.9.0 || ^17.0.0 || ^18.0.0 || ^0.0.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > @mdx-js/react@2.1.4" has unmet peer dependency "react@>=16".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-plugin-sharp@4.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > theme-ui@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > prism-react-renderer@1.3.5" has unmet peer dependency "react@>=0.14.9".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > gatsby-plugin-catch-links@4.24.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-gatsby-cloud@4.24.0" has unmet peer dependency "webpack@*".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/mdx@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/mdx@0.15.1" has unmet peer dependency "@types/mdx@^2.0.2".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > gatsby-plugin-theme-ui@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > gatsby-plugin-theme-ui@0.15.1" has unmet peer dependency "gatsby@^4".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > gatsby-plugin-theme-ui@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-transformer-sharp > gatsby-plugin-utils@3.18.0" has unmet peer dependency "gatsby@^4.0.0-next".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog-core > gatsby-transformer-sharp > gatsby-plugin-utils@3.18.0" has unmet peer dependency "graphql@^15.0.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > theme-ui > @theme-ui/theme-provider@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > theme-ui > @theme-ui/color-modes@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby-plugin-gatsby-cloud > webpack-assets-manifest@5.1.0" has unmet peer dependency "webpack@^5.2.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > theme-ui > @theme-ui/components@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > theme-ui > @theme-ui/core@0.15.1" has unmet peer dependency "react@>=18".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby > eslint-config-react-app@6.0.0" has unmet peer dependency "babel-eslint@^10.0.0".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > minimal-blog > gatsby > react-server-dom-webpack@0.0.0-experimental-c8b778b7f-20220825" has incorrect peer dependency "react@0.0.0-experimental-c8b778b7f-20220825".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-bulma@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-base@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-future@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-dark@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-deep@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-bootstrap@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-polaris@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-system@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-tailwind@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-swiss@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-roboto@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-funk@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:00:54 PM: warning "workspace-aggregator-9573b8b0-e40c-4dae-b273-8e10f3856cc6 > @lekoarts/gatsby-theme-minimal-blog > @theme-ui/presets > @theme-ui/preset-tosh@0.15.1" has unmet peer dependency "@theme-ui/css@^0.15.1".
4:01:18 PM: [4/4] Building fresh packages...
4:01:27 PM: success Saved lockfile.
4:01:27 PM: $ yarn packages:build
4:01:27 PM: yarn run v1.22.19
4:01:27 PM: $ cross-env FORCE_COLOR=1 yarn workspaces foreach --parallel --interlaced run package:build
4:01:28 PM: error Invalid subcommand. Try "info, run"
4:01:28 PM: info Visit https://yarnpkg.com/en/docs/cli/workspaces for documentation about this command.
4:01:28 PM: error Command failed with exit code 1. (https://ntl.fyi/exit-code-1)
4:01:28 PM: info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
4:01:28 PM: error Command failed with exit code 1. (https://ntl.fyi/exit-code-1)
4:01:28 PM: info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
4:01:28 PM: Creating deploy upload records
4:01:28 PM: Error during Yarn install
4:01:28 PM: Build was terminated: Build script returned non-zero exit code: 1
4:01:28 PM: Failing build: Failed to build site
4:01:28 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1 (https://ntl.fyi/exit-code-1)
4:01:28 PM: Finished processing build request in 1m44.397360676s
1 Like

HI @jassimahmed

Have you tried setting the YARN_VERSION environment variable?

While not directly related (possibly) you might find this issue interesting

1 Like

Yes, I used YARN_VERSION already. It’s not able to download anything 3.2.X. Honestly, I am a bit confused. I don’t know anything about Yarn. It seems the latest version is 1.22.19 which is what Netlify downloads but my mac has 3.2.X.

11:30:19 AM: Installing yarn at version 3.2.3
11:30:19 AM: Installing Yarn!
11:30:19 AM: > Downloading tarball...
11:30:19 AM: [1/2]: https://yarnpkg.com/downloads/3.2.3/yarn-v3.2.3.tar.gz --> /tmp/yarn.tar.gz.gbozuGRTvy
11:30:19 AM:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
11:30:19 AM:                                  Dload  Upload   Total   Spent    Left  Speed
11:30:19 AM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
11:30:19 AM: 100    77  100    77    0     0    368      0 --:--:-- --:--:-- --:--:--   370
11:30:19 AM: 100    90  100    90    0     0    240      0 --:--:-- --:--:-- --:--:--   240
11:30:19 AM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
11:30:19 AM: curl: (22) The requested URL returned error: 404 Not Found
11:30:19 AM: [2/2]: https://yarnpkg.com/downloads/3.2.3/yarn-v3.2.3.tar.gz.asc --> /tmp/yarn.tar.gz.gbozuGRTvy.asc
11:30:20 AM: 100    81  100    81    0     0    433      0 --:--:-- --:--:-- --:--:--   433
11:30:20 AM: 100    94  100    94    0     0    362      0 --:--:-- --:--:-- --:--:--   362
11:30:20 AM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
11:30:20 AM: curl: (22) The requested URL returned error: 404 Not Found
11:30:20 AM: > Failed to download https://yarnpkg.com/downloads/3.2.3/yarn-v3.2.3.tar.gz.
11:30:20 AM: mv: cannot stat '/opt/buildhome/.yarn': No such file or directory
11:30:20 AM: No yarn workspaces detected

I think the problem is Netlify does not download β€œBerry”: GitHub - yarnpkg/berry: πŸ“¦πŸˆ Active development trunk for Yarn βš’

Is there a need to use Yarn for this project? Could you not use npm?

It’s not because it does not, but because it can’t. The issue below

because the URL is returning a 404 Not Found.

This download URL

https://yarnpkg.com/downloads/3.2.3/yarn-v3.2.3.tar.gz

redirects to

https://github.com/yarnpkg/yarn/releases/download/v3.2.3/yarn-v3.2.3.tar.gz

However the berry package uses a different repository yarnpkg/berry. It also doesn’t have packages available under the /download/ path (as the Classic version does.) As this redirect it (seemingly) handled by Yarn, it is not something Netlify can fix.

If there is an opportunity that Netlify can change the URL internally they download from I don’t know.

I ran into this issue too. Are you using Node v12?

I was using v12, and getting this error. I tried using v14 ( and YARN_VERSION=3.2.1 ) and was able to deploy successfully.

Hi @iDreamCM

As the log above shows node 16 was used.

Node.js v12 has reached end of life and is no longer supported. v14 reaches end of life in April 2023, so you are best to switch to v16.

1 Like

Thank you Coel! @iDreamCM, let us know if you have additional questions!