Why is my site not updating changes

Hey there, I have a site hosted on Netlify and when I go to make changes its not updating.

1.) git add .
2.) git commit -m “new commit”
3.) git push

  • 4.) can then see the updated files on github

After all of this no change to my Netlify site. What do I need to change?


Please let me know,



And when I try to make a new weblink on Netlify for my project it just says “site deploy in progress” so is something up with Netlify’s servers as even trying to make a new project for my site wont load now.

Hi, @dobs93. There was an issue with sites without any build command (like this site) not deploying which has been resolved now.

If you trigger new deploys of this site with a git push (or with the buttons in the web UI), it should work correctly now. If you still see builds without a build command not completing, please let us know.


Unfortunately still not working for me. The same site before the git push is still active even though the updates are being uploaded to Github.

Anything else you recommend?

can you link or paste a deploy log from a failed build please?

Hiya, sorry you are having trouble with your build.

Also, this Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!


Here is the deploy log when I tried to create a new project for the same site.

11:02:53 AM: Build ready to start

11:02:55 AM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6

11:02:55 AM: build-image tag: v3.4.1

11:02:55 AM: buildbot version: 0e3cc7aef5c33f731b54ed4b65d515eaab821679

11:02:55 AM: Fetching cached dependencies

11:02:55 AM: Failed to fetch cache, continuing with build

11:02:55 AM: Starting to prepare the repo for build

11:02:55 AM: No cached dependencies found. Cloning fresh repo

11:02:55 AM: git clone https://github.com/dobs1993/Imagineers

11:02:57 AM: Preparing Git Reference refs/heads/main

11:02:58 AM: No build command found, continuing to publishing

11:03:02 AM: Finished processing build request in 7.268566701s

I’m not sure what else could help I’ve never had this issue before. Let me know if there’s anything else I can provide.

Here is a deploy log when I pushed changes to Github. I can see it failed to deploy now under my “deploys settings tab” on Netlify.

8:21:57 PM: Build ready to start

8:22:04 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6

8:22:04 PM: build-image tag: v3.4.1

8:22:04 PM: buildbot version: 0e3cc7aef5c33f731b54ed4b65d515eaab821679

8:22:05 PM: Fetching cached dependencies

8:22:05 PM: Starting to download cache of 51.6MB

8:22:05 PM: Finished downloading cache in 898.859393ms

8:22:05 PM: Starting to extract cache

8:22:06 PM: Finished extracting cache in 505.103657ms

8:22:06 PM: Finished fetching cache in 1.422473374s

8:22:06 PM: Starting to prepare the repo for build

8:22:06 PM: Preparing Git Reference refs/heads/main

8:22:08 PM: No build command found, continuing to publishing

8:22:12 PM: Finished processing build request in 7.439772468s

I’m guessing something has just been changed on your end as the site is now live again with changes in effect. It’s published in the deploy log and I can see the site preview in the image box.

hi there, this issue was caused by a problem on our side we discovered shortly after you posted. We have since remediated things, and you shouldn’t have any more problems!

1 Like

Great thanks for the help. Appreciate it.

1 Like

Hi there, I’m currently having this same exact issue and can’t seem to get it working. Any help would be much appreciated!

hey @ryan-neil , please start a new topic and let us know which site this is regarding (netlify site name or API ID). You’ll also want to let us know what you have tried already to debug, etc! thanks.