Website displays 403 permission denied error sometimes!


I am Timothy Jao and I own the domain Recently it was brought to my attention that my website would throw a 403 error that says something like “Permission denied. You do not have access to /”. I could not reproduce the error for a while. It wasn’t until I connected to a public wifi was I able to reproduce it on my phone. However, when I switched to my data, it works and no longer gives the error. Have any of you seen this issue before? What steps should I take to fix this?

Thank you.

Hi @timothyjao - welcome to our forums! Am I correct in understanding that this error only occurs when you are on some (potentially less reliable) networks such as public wifi?

Hi Perry,

I cannot guarantee for sure that the public wifi is what causes it. I was only able to reproduce the issue because I tried using my gym’s wifi. Once I switched to my data plan for my phone it worked. I talked to my friends who reported it breaking and they said that they were using home and work wifi.

Hi @timothyjao!

That doesn’t sound like it comes from our service since we don’t show any error like that - if we deny permission, it generally is looks like this:


You can be sure though! I’d suggest that when you find someone kinda nerdy who can reproduce it, you have them look in the browser developer tools and see if we sent the response. No matter what status code it is, we will always send a “server: netlify” HTTP response header as shown here:

If we host your content, but any response doesn’t say “server: Netlify” like that - it came from some other service such as a local network proxy (or a different 3rd party).