"Waiting on DNS propagation" seems stuck

I am trying to set up the SSL certificate for my site (https://taller-iatext.ivanhercaz.com). I already create the CNAME poiting to my Netlify site (https://taller-iatext.netlify.com).

Everything seems fine but there are two problems:

  1. The DNS propagation message (“Waiting on DNS propagation”) seems to be stucked for hours. I tried to click “Verify DNS configuration”, sometimes appears the next message:

DNS verification was successful.
If provisioning your certificate takes longer than 24 hours, please contact support"

But another times the message is:

DNS verification failed

  • taller-iatext.ivanhercaz.com doesn’t appear to be served by Netlify
    We can’t provision a certificate until your DNS configuration is pointing at the Netlify servers and the changes have propagated.
    If you’ve already changed your DNS configuration, allow up to 24 hours for the changes to be processed, or check our troubleshooting guide for some tips on what might be happening.
  1. This is causing issues on my site (stylesheets are not loading due certification error). At this moment I am not very worry about it because the site is being tested and I am not sharing it with my students, but I will need it working as soon as possible because I need to spread it.

I know there are a lot of another posts on this forum about it, but I see that sometimes it is fixed by the intervention of some worker of Netlify, so I decided to post my case.

P.S. I already have another site configured in the same way (buruma.ivanhercaz.com points to buruma.netlify.com with a CNAME) and the SSL works fine.
P.S. (for second time) The CNAME seems to be propagated correctly as DNS Checker indicates.

The problems seems to have been solved. The site is using correctly the SSL certificate provided by Netlify and now all resources load correctly. And now in the “SSL/TLS certificate” section appears the details of the certificate correctly.

I understand that what it needs was to be propagated adequately and in this time it was slower than another times I configured sites on Netlify. It seems the solution has been to be patient.

Excuse me the possible inconvenience of open this thread for a problem that has solved itself!

P.S. Or it may be that someone have make something in the shadows of Netlify hehe.

Hi, @ivanhercaz, and welcome to our Netlify community site.

My best guess is that the issue was caused by delays in DNS record changes to the the “time to live” (TTL) value in the previous DNS records which control how longer non-authoritative DNS servers cache those records:

I’m glad to learn it is working now and there is no inconvenience for posting the question about (and solution for) this here. Hopefully, this will be helpful to others searching for similar issues. Thank you for sharing your experience!

1 Like

Thank you very much for your answer, @luke! Yes it seems what happened. I will keep in mind this for next similar issues and be relaxed about my own answers that solves the threads I open.

Thanks to you and all the Netlify team for provide this awesome service.