Error - Certificate isn't trusted, RemoteCertificateNameMismatch

I bought a domain from truehost. used Netlify’s DNS to point my Domain to netlify servers .The propagation has worked succesfully .
.But the problem is the certificate issue has taken more than I expected.
Its now 3 days since i set up the name servers.Whenever i try visiting my site dowlladahahoosekgs.com am welcomed with this ssl error

Your connection is not private

Attackers might be trying to steal your information from dowlladahahoosekgs.com (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_COMMON_NAME_INVALID
and this wouldn’t be so nice for my users.
I tried debugging the problem so I visited this site check-your-website.server-daten.de and i was able to take some screenshots of the checks

image
please help me out

The problem was resolved,what it needs actually its time and be so patient it take about 4-3 days to issue a certificate but if if fails or displays an error that we could not provision a ssl certificate just retry manually this way

In a few minutes or seconds its gonna issue the cert.

Hi @glennin-codes,

Thanks for reaching and then updating and letting us know you resolved the issue.

It can take time for DNS changes to propagate. We have a Support Guide covering this here:

I do see that your using Netlify name servers and that the SSL Certificate has been successfully provisioned on your site.

1 Like