Vuepress deployment no images


I deployed a vuepress site and it shows me no images. I installed netlify-cli and if I test it with netlify dev it shows me all the images, also if I build and run a server also works.
I even try and add the same build directory to and there it works.

I have all my images in: src/.vuepress/public/images/ folder.

Instance Name:

I get no build log errors.

Any help is appreciated. Thanks in advanced,

hey marius,

when i pull open your website and look at the browser console, this is what i see:

there is obviously something wrong with either the files not being uploaded, the files not being in the right place for the template to find. This might be a absolute vs. relative path issue?

Yea I know the message in the browser console, but I don’t know why this happens.
This is my dist folder after I build it locally and all images are in the images folder:
Screenshot 2020-03-10 at 18.53.49

On images I use :src="$withBase('/images/image-name.jpg') it’s strange because when I run netlify dev everything works as it should with all the images showing.

I have to specify that I Eject the theme:

Thanks for the fast response.

this came up in another thread, seems worth checking: do you have a .gitignore, and if so, can you check and make sure it isn’t excluding something it shouldnt?

Thanks a lot. Don’t know how I didn’t check that, my public folder was on .gitignore file.

1 Like

Damn! Of course! Glad the mystery is solved, I was really scratching my head on this one :+1: