Upgrade web page (problem)

Hi, i have a problem to upgrade my web page!!


I just updated my portfolio on Github but the changes are not reflected in netlify, I wanted to know how I can get the changes and if that can be done automatically?

Thank you

Are you wanting to using continuous deployment? Did you configure your github repo to Netlify? Build configuration overview | Netlify Docs

1 Like

rolling update is already active

In the most recent build, does it should new files were uploaded

Or that all files are already uploaded?

The latter indicates there is nothing new e.g. no new content pages, or style changes.

The former indicates any/all new content was uploaded. If this is the case and you still don’t see the changes reflected on the site, quite possibly it comes down to cache on your computer. You can test this by trying an incognito/private browser window, a different browser, or a different device.

Failing this, can you share a screenshot of what you are seeing versus what you are expecting to see, and the git repository you are deploying from,

1 Like

Hi, @Lorensio. The branch you are pushing commits to is not the same branch you have configured for production deploys at Netlify. This setting is found under:

  • Site Name > Settings > Build & deploy > Continuous Deployment > Branches and deploy contexts

If you go to that setting, you will see the production branch is “main”. However, the branch your recent commits are pushed to is named “master”.

This is the reason the site doesn’t update. You are not updating the production branch. If you push the commits to that branch or if you change the production branch to “master” that will resolve the issue.

If there are other questions or concerns, please let us know.


Hi @luke, I changed the Main branch to Master, but the page dosen’t change, does it update itself?

Thanks for the help!

now, the page is white…

The asset sources in the elements below explain that.

What are the build/deploy settings you are using?


It’s made with react js if that’s what you mean

The same thing is happening to me as here:

he puts me ahead of /lorenzomunoz/

How do I stop it from posting that?

No, that is not. What are the build settings for the projects as seen in the Netlify UI? e.g.

What directory are you publishing?
Is there a homepage key/value set in the package.json?
Can you share the repository you are deploying from?

repository: GitHub - lorenzo-mm/Portfolio: Portofolio

The homepage value in the package.json is incorrect as it is not a valid URL (it is missing the protocol e.g. https://). This key is not required for most React projects as I outlined in the following post

I suggest removing the homepage key.

The path for the favicon.ico does not work when building. Any asset not referenced inside React e.g.

import Carpeta from '../../assets/icons-languages/icon-animated/Carpeta.gif'

does not get copied to the output directory during build. The favicon.ico should go into the public directory alongside the index.html and /src/assets removed from the href inside index.html.

I can confirm this works as I have tested your repository locally.

Do note none of this is anything to do with Netlify. It is entirely the setup of the project. You can test this locally before deploying to Netlify by running npm run build and checking the output. Using a package such as serve or http-server to serve the locally built content and view as you would when deployed is a good idea too.

1 Like

good morning!!

I change the favicon.ico to public with index.html and its works. :white_check_mark:

I removed the homepage key, i don’t know why that was there :white_check_mark:

I have tested the page as you have told me, and it works locally, it is true. now changing those things that you have told me works perfectly on Netlify, I know it was my mistake and not theirs because it had already happened to me at the beginning of publishing it. :white_check_mark:

I still have to know how to move to upload the pages
Thank you very much for the help and patience :heart: :clap:

1 Like