updateSiteDeploy default &{Code:0 Message:}

I need advice to debug deploy https://app.netlify.com/sites/formacaoglobal/deploys/5e9193b6f2fcfcf70d9cbd67

11:56:15 AM: Build script success
11:56:15 AM: Starting to deploy site from 'dist'
11:56:15 AM: Creating deploy tree asynchronously
11:56:15 AM: Failing build: Failed to deploy site
11:56:15 AM: failed during stage 'deploying site': Failed to execute deploy: [PUT /sites/{site_id}/deploys/{deploy_id}][500] updateSiteDeploy default  &{Code:0 Message:}

This started happening after changing the repository (from bitbucket to gitlab), the deployment worked in a temp site.

Hi, @marcosmesser, there are some errors relating to those failed deploys which imply that this might be Large Media related.

Are you using Large Media with this site? Or are you using a Git LFS service hosted elsewhere (for example at GitLab)?

If you are using GitLab’s Git LFS service we need to disable the Large Media configurations for thi site. If you are still using Large Media for Git LFS, we’ll troubleshoot that in more detail.

Hello @luke, thanks for looking into it.

I was using Large Media, not Gitlab’s.

Taking advantage of Github’s announcement, I imported the repo there and linked it to Netlify.

However, the same error happened: https://app.netlify.com/sites/formacaoglobal/deploys/5e96c5cc5ad6c60859308661

Before posting here, I’ve tried re-linking the localproject (netlify-cli) and redoing the setup for large media.

If I use the cli to deploy, it works.

Hi, @marcosmesser.

We have sent you an email to the email address associated with your Netlify account, and we’ll communicate with you through that email to continue resolving this issue.

Also, please let us know with a reply here if you don’t receive a message from us.

Thanks @luke.

After re-installing, re-linking, basically rebooting everything, the deployment worked.

There was an issue after with some images not loading, but it was caused by asset optimization.

Everything is working now.

Hi, @marcosmesser, yes, that asset optimization incompatibility is a small detail and easily missed for that reason.

There are open feature requests for both the API and the CLI to check for asset optimization and for both API and CLI to refuse to initialize Large Media if asset optimization is enabled for the site.

If/when these feature requests become realities, we’ll let you know about it with a follow-up post here.

Edit: The CLI issue is public and can be found here.