Unable to renew SSL Certificate!


I am having issues with certificate renewal. I am getting the following error:
"SniCertificate::CertificateNonvalidError: Unable to verify challenge for preview.mah.alyssakirstine.com: 2600:1f18:2489:8201::c8: Invalid response from http://preview.mah.alyssakirstine.com/.well-known/acme-challenge/UA5mEhqnecFJfetBRLm7RVRGEllx2bMz9Vsa6Lh9jD8: 404

We can’t renew your Let’s Encrypt certificate automatically until the issue is resolved. Check our troubleshooting guide for more information on how to fix the problem, and then renew the certificate."

It looks like it’s trying to renew the cert for “preview.mah.alyssakirstine.com” as well which is where the problem is happening. I’m no longer using that particular domain, just the “*.millersapplehill.com” and “millersapplehill.com” ones. I don’t have it set up anywhere, but for some reason the system is trying to renew it.

My Netlify site name is : millers-apple-hill.netlify.app
And the custom domain is: https://millersapplehill.com/

Help much appreciated,


millersapplehill.com is not configured for use with Netlify. The DNS records need configuring either using Netlify DNS or with external DNS.

Check out

preview.mah.alyssakirstine.com is however pointing to the site millers-apple-hill.netlify.app as is mah.alyssakirstine.com.

Hi @AlyssaKirstine :wave:t6: welcome to the forums! @jasiqli is correct. If this doesn’t automatically renew after you update your DNS setting please do not hesitate to reach out.

I think my client changed the DNS settings… I just switched it back and tried to renew the certificate. I’m still getting the same error.


DNS propagation isn’t instantaneous. It can take up to 48 hours

Hi @AlyssaKirstine :wave:t6: ,

The issue is that the SSL certificate was extended for branch subdomain. Undo that and it will work.

How do I do that? I can’t figure it out through the Netlify interface.


Based on your site settings now, this appears to be solved.

Yeah, it’s fixed. Thanks for the help. I ended up deleting the Netlify site and setting it up again since nothing else was working. I tried removing the branch subdomain and it didn’t fix it. The SSL certificate was still trying to renew the mah.alyssakirstine.com domain which was causing the error. I set the new site instance up in the same way and it works fine. So it seems like it was potentially a bug or glitch in the Netlify interface.