TypeError: Cannot read property 'activities' of undefined

I need advice to debug deploy https://app.netlify.com/sites/epic-sammet-97acf3/deploys/5ea68c895418c36f1b1d72e2

Build is failing which is strange as it works on my local and the only difference between the previous build and the new one is the one where I added few more md files. No configuraiton changes. Can someone please help with this?

Github link: https://github.com/nerdyhorse/nerdy-horse-blog
in case someone needs it to debug it.

I even reverted back the code to the last successful deployment. It is breaking for them too.


hey there,

this seems to be a gatsby error:

if you scroll down to the bottom, you can see some tips that might help:

"I was seeing the same issue in our ci after a package-lock file update, which worked fine locally. gatsby-cli is not in in package.json, but added to package-lock.json as dependency of gatsby.

Bumping gatsby version to 2.20.24 (and clean reinstall, reset of package-lock) solved it for me as well. I never saw this on my local environment though."

Actually I fixed it.
The issue was gatsby-cli recently had a version bump, which was breaking the older gatsby versions. I bumped in my system and could reproduce the issue. All I had to do is bump up the gatsby libraries I was using and it fixed the issue.

1 Like