Trouble deploying static website

Hello everyone!
I just picked programming back again and I have trouble deploying a static website I built a few years ago. You can see the repo for my site here.
My netlify website address is
I get the error that says ‘page not found’ and I checked the publish deploy page and this is the error.
It has something to do with insecure mixed content detected.
At first, I thought it was the publish directory in which case I put in ‘public_html’. I am new to using this so I gladly appreciate it if you are thorough with the explanation and details of why my website did not deploy. Thank you!


Your site files are in public_html, but you published your entire GitHub repository. You need to tell Netlify to grab only the files in public_html.

If you go here, you’ll see your site:

I put ‘public_html’ as my publish directory which should work but it is still giving me the same error.

EDIT: I figured it out. Instead of putting ‘public_html/’ I forgot to put the backslash after the folder. It works now thank you!

1 Like