"This site can’t be reached" after enabling identity on netlify

I was able to access my webpage when I deploy and all seems to be working well. But couldn’t again after enabling identity.
Please, I need help with this.

What website are we talking about here?

It’s a portfolio website.

Built with Gatsby and Netlify-cms

Is the identity still enabled? The website is loading fine for me.

I have also seen some cases where you’d get such an error after you install the service worker. So, do you know if that’s the case?

Yes, it’s still enabled. But it’s still not working at my end here.

It’s build with Gatsby and netlify-cms

https: github.com/sadewole/samador.dev And the deployed branch is pages-cofig

I don’t think it’s Identity issue. Now your website went down for me too because I visited it before and the service worker got installed. Identity has nothing to do with your website’s network. So in your case it’s the problem of service worker. Disable it and your website will work.

If you want to verify, try loading your website in incognito. If it loads there (it loaded for me), It’s the service worker.

Okay… I’ll try to disable the service worker then.
But it’s been working fine until I tried enabling the identity tho.

That might have been a coincidence. But here’s a thread that mentions the same issue caused by service worker: Domain went down after installing my site into mobile device

That’s why I guessed your problem to also be related to sw. If at all it’s because if Identity, I’m sure it will be a temporary problem and would automatically get fixed.

1 Like

Thanks, @hrishikesh. I realize the main issue was from the service worker. Is there any solution to this since I’m using workbox with gatsby-plugin-offline?

You can try this: Cached version of website not updating on new build/repo change

Not sure how you can integrate it with the plugin though. Maybe, you can remove the plugin, add a custom service worker and add that code to your gatsby-browser.js.

Hi
Please, do you know how to dynamically add the cacheAll assets on gatsby SW.

// SW cache assets
const assets = ["/"]

// install SW

self.addEventListener(“install”, e => {

e.waitUntil(

caches

  .open(staticCacheName)

  .then(cache => cache.addAll(assets))

  .then(() => self.skipWaiting())

)

})

You can check the source code of gatsby-plugin-offline to find that out.