This function has crashed - Nuxt 3 production

I am having issues with my website I have reverted back any changes and I am still getting this error even though I don’t use any netlify functions.

This function has crashed
Runtime.ImportModuleError - Error: Cannot find module 'server' Require stack: - /var/runtime/index.mjs

Is this a Netlify issue or do you think it could be a Nuxt 3 dependency issue? Really worrying as my live website has been down for the last hour :frowning:


I’m experiencing the same, did a deploy this afternoon everything was fine.
You can deploy an older version which will at least bring back your site

I’m also on nuxt3

Hi @monkemedia and @g.vanengelen, :wave:t6:,

Thanks for reaching out!

This is not a Netlify issue, Nuxt manages its own integration.

Here is the Nuxt 3 repo: Issues · nuxt/framework · GitHub. I believe there would be an issue there sooner or later.

Hello @SamO , I am a lead developper of BullvBear. Since this afternoon, I am having exactly the same issue than @monkemedia and g.vanengelen .
Our Nuxt 3 on Netlify was working fine for 3 months straight. We didn’t update any dependency recently, nor Nuxt 3 got any recent updates.
We reverted our last commits to some old ones that had “Previews” working fine. And when we rebuild them, we get this exact same error.
We don’t have any problem on localhost, nor on a custom VPS.
I deeply think that something changed on Netlify Lambda function behavior. Maybe my intuition is wrong, but if you get more feedbacks like this, please consider an investigation.

Best regards,

1 Like

You shouldn’t revert the changes, you should just lookup an older deployment in netllfy. And publish that again. Creating new deployments doesn’t work.

1 Like

Since I could not find an issue I created on myself

But Nuxt hasn’t had a release since November. Seems like something changed on the Netlify side today. Any clues?

1 Like

i believe it’s netlify side as well

I must admit, I am kinda relieved that its not just me. Really hope this can be resolved asap.

I too had to re-deploy an older version of my app via Netlify. Reverting changes it Github and pushing the changes did not work for me neither :frowning:

Has anyone tried changing the preset to netlify-edge preset as workaround suggested by gjvengelen on the github issue?

This runtime error is taking place even when you do a clean install.

This is what I did:

  1. Installed Nuxt 3 application using: npx nuxi init [project-name]
  2. Installed dependencies with: npm install
  3. Created a git repo and then uploaded to GitHub
  4. Created a Netlify Site and connected it to my GitHub repo
  5. Deployed the site with default values
  6. Netlify shows the deployment as “Published”
  7. When you go to the Netlify URL it shows:

Runtime.ImportModuleError - Error: Cannot find module 'server' Require stack: - /var/runtime/index.mjs

This is without ANY changes to the Nuxt 3 installation and doing everything from default.
Any ideas on how to solve this?

Thanks managed to get an old version of my site back up

these to repos had updates today.

Works on Vercel :wink:

Exact same repo.

THe issue seems to have been resolved

Thanks everyone for your reports. As @g.vanengelen pointed out, this has now been resolved. If you redeploy your site it should fix the issue. Thanks for your patience. The issue was that a change made to the way we bundle ES modules in functions caused problems with the server entrypoint generated by Nuxt 3. We’ve rolled-back that change and will investigate further what happened.