[Support Guide] I’ve deployed my site but I still see "Page not found”

@flityzz you should start with: vue create hello-world

This will show you how a vue project gets scaffold to include all your assets into a dist folder on build. You should be able to pick most of the default options to get a clean project.


@luke Thanks for the reply, here is my repository: https://github.com/flityzz/discord-vue

As @talves said, I should have started my project with ‘vue create [project]’, instead I created it with ‘vue webpack-simple’. The Vue webpack-simple template does not create a finished build folder. It assumes you will be hosting your site from the root of the project. so thanks anyways for the replies

UPDATE: actually, your stack overflow answer worked! thanks, i was forgetting to commit the netlify.toml file to the repository, so i added the file and it worked! thanks @luke and @talves

@talves deserves all the credit on this one! :+1:

1 Like

A post was split to a new topic: Page not found for route “/login”

A post was split to a new topic: How do I make the site subdomain netlify.com and not netlify.app

2 posts were split to a new topic: “Page not found” for ‘nuxt build’ command (‘nuxt export’ possibly needed)

Hi everyone,
I need help because Netlify says Site is live but cannot find it. I have read your suggestions above and downloaded a copy of the deploy but cannot read anything from there (because I am not familiar with this process) can you help me to find the website please?

@mathieujulien99 Welcome to the Netlify community.

Please provide your Netlify site name, domains, and other information when you post. The better the post = the faster we can help!

Site name: Island Tribes Challenges
Site domain: islandtribeschallenges.com
URL: https://www.islandtribeschallenges.com/


@mathieujulien99 OK, after your download a copy of your deploy, you will find a file called something like deploy-5f6fafe4f8986e0008994f3d.zip.

You unZIP this file (AKA unarchive), which typically can be done by double-clicking it. This will result in a new folder in the same directory as the ZIP file with the same name as the ZIP file, but without the .zip file extension.

Open the new folder.

Inside, you should see your site files. If you see only another folder, or a bunch of files without one named index.html, that’s your problem. You MUST have an index.html file at the top level of your site for your site to load when people visit your domain URL.

If your main index.html file is inside a folder, you need to figure out how to build / deploy your site so that your site files, including especially your main index.html file, are at the top level, not hidden inside a folder.

If you see only a folder inside your site folder, you should be able to see your site by going to https://www.islandtribeschallenges.com/foldername/.

Hi Greg, thank you for your help and patience.
I have followed your instructions carefully.
But I don’t receive the index.html among the other folders when download the zip file,
and this even when I do other deploy trials with other templates.

mathieujulien99 Then you know what you need to fix. Somehow, you need your build process to generate an index.html file at the top level of your website.

1 Like

domain: https://sixtomidnight.productions

I’m using a branch deploy of staging to test out a the example form element and on submit it’s hitting me with “404 page not found”… Does the form need to be on the production branch?

no, forms can be on any branch, this is likely resulting from something else.

Do you have an index page for that domain?

domain : nervous-curie-686902.netlify.app

The build works on my computer but it doesn’t on Netlify

Hey there, thanks for reaching out.

What you are describing sounds a bit like a an issue with case sensitivity on our system.

Can you give this a read through and let us know if that fixes the issue?

I’m having this same problem. I’ve written a React application. I have an index.html file in my public folder which is where I set the publish directory. Deploy says successful but I get 404. netlify.toml has rewrite as shown in docs. Help please :slight_smile: thanks!

Ok, now I am not getting the page not found message, but I get a blank screen. This is not making any sense. Builds fine locally. I’ve changed my file structure(which is why I’m not getting page not found anymore) but still no joy.

Hello, if anyone can help that will be amazing, i still new to netlify and when i do get the error page not found but it says website have been published. I did go over the information on how to debug that but still, i am currently struggling, also when i try to download the zip file it throws an error that it can’t download the zip file. please help. thanks