Suddenly not building

I need advice to debug deploy

I can’t seem to find anything that I’ve changed since the build was working. I’ve tried everything I could find through Google and these forums without luck.

It’s a create react app that has been consistently building properly and suddenly has an issue. Built right at 11am today, then next deploy at 5:30pm failed.

Any other ideas? I could really use some help :slight_smile: Thanks!

I have been having the same issue! Using create react app as well, had a working build a week ago, did some few minor text changes and pushed the changes to git and now it is throwing me build errors. Tried clearing cache, deleting node_modules and package-lock.json and re running npm install. still didnt work. Posted my own thread but no responses yet :confused:

Set CI=false in the build command, it might work.

1 Like

@doublepithre It’s building successfully now. Thank you so much! Spent ages trying to figure this out… :pray:

Hey! Apologies in advance for the following copy/paste response. If I don’t clear anything up and/or your problem persists, please do reply.

This build may have failed because of the introduction of an unplanned change to builds in the last 24 hours. In your failed deploy log, you may see the line: Treating warnings as errors because process.env.CI = true

Basically, this change would mean that your site won’t deploy if there’s warnings. Although we plan to introduce this in some capacity in the future, like most other CI platforms already have, now wasn’t the time and we’ve rolled this back.

TL;DR: if you re-deploy your site now, it should work! If not, please reply.

If you’re still following along, anybody who has made temporary fixes (i.e. CI=false) can now remove them :smile:.

1 Like