Submitting a form gives a 404 Page not found


I’m trying to integrate forms into my site and each time keep getting a 404 Page not found error whenever I submit a form. The form name is being picked up within the forms tab on the Netlify admin panel. I have even copied the HTML from the docs (Forms setup | Netlify Docs) but that is also giving me a 404. Live form is here (

Can anyone give me any tips to try and debug this?


hi there, sorry to hear you are struggling with a 404. Your first port of call is this doc:

additionally, a quick search reveals that a ton of people have posted (and gotten answers) on how to fix 404 errors with their forms, so you might work through those threads first.

if still struggling, let us know and we’ll try to help.

1 Like

Hi @perry,

I’m getting the 404 error message after I tried to submit the form. I used the example of the form that he shared on his repository and made a few modifications.

This is the code for the form:
veronicalara/src/components/contact at master · ManudeQuevedo/veronicalara · GitHub.

I uploaded the site to Netlify, for if you wanna try it:

SIte is in Spanish by the way.

I generated the sitekey using my Google account, and placed it on the code, I’ve tried to research about the Recaptcha config, and also to check if there are any workaround for the Reaptcha npm package, but I barely found information for that.

@ManudeQuevedo i have merged your post with @bencarter78 are you are both likely dealing with similar issues. Go ahead and work through the post I linked above, as well as reviewing the other posts in this forum that also describe the same problem, thanks!

1 Like

Thanks a lot @Perry, I’ll try this to see if it fixes the error.


1 Like

Hi! I still have the same issue, I think problem is with the recaptcha, I validated line by line on my code and it is pretty much the same as the original code from the repository I used as example.

Here is my repo: GitHub - ManudeQuevedo/veronicalara: New and improved website using react.

Site is in spanish but I would love to know what might be the problem for getting the 404 error code.

Any detail needed, feel free to ask me.

Thanks in advance!

Hola Manu!

I’m on my phone so I didn’t test this, but check the name attribute of your forms.

It seems to be different in the index.html file and in your Formik config.

1 Like