Support Forums

Stuck on 'Site deploy in progress'

I just deployed a website on netlify using a github repository.
The website works and loads fine locally on localhost:8000

Right now the logs are telling me that the server is running:

12:02:13 AM: Executing user command: npm start
12:02:13 AM: > ocm_minting_tool@1.0.0 start /opt/build/repo
12:02:13 AM: > node server.js
12:02:14 AM: App running on port 8000

However, it is currently stuck on “Deploy in progress” and the website returns “page not found”.

My server.js in in the root folder and the html pages are in a child “client”
image ![image|577x203]

I’m a bit of a newbie on netlify, have I missed something?

Thank you

hi, welcome! hmm, i don’t think npm start is the right command, that is usually just for spinning up a server on localhost which is different than deploying your site to netlify. :thinking:

This Common Issue contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

Hi, I solved it by adding a “build” script to my package.json and setting it to “node server.js” it’s working fine now.

Thank you!