Site not getting updated


Builds started failing on Thursday with no code changes.

Our developers tried a few things:
We updated to the latest Essential Gatsby netlify plugin and gatsby-plugin-netlify versions.
We tried removing the Essential Gatsby plugin entirely.
We tried several times to rebuild the site without cache.

At a loss for why Netlify wasn’t able to build the site, we built it locally using yarn build and then deployed the site manually from the command line. This seemed to work so we switched the site from using automatic builds through the Netlify CI to GitHub actions.

- Hashing files...
✔ Finished hashing 
- CDN diffing files...
✔ CDN requesting 28 files
- Uploading 28 files
✔ Finished uploading 28 assets
- Waiting for deploy to go live...
✔ Deploy is live!
Deploy path:        /github/workspace/public
Configuration path: /github/workspace/netlify.toml
Deploying to draft URL...

Although the above shows Deploy is live, our changes are not seen on the draft url.

The GitHub action file is currently configured to deploy to Netlilfy on branch commits to master, qa, and modular-page. This deploys via the Netlify CLI using the --alias flag to create a branch deploy like modular-page–

However, at present the site is still not updating. Despite the manual deploys we are not seeing new code changes reflected on the Netlify site.

Thanks for your help with this.

Hi, @seso. This explains what you are seeing:

The --alias option does not make branch deploys. You cannot use any branch deploy feature with --alias deploys because that feature only works with a build and deploy at Netlify.

There is an open feature request to make --alias work with branch deploy features but that isn’t possible at this time. If there are other questions or concerns, please let us know.

1 Like