Site is live, but sill blank screen (react app)

In your package.json, change homepage to /.

thank you so much…it worked

make sure to to delete the html files in the public folder. These will override your pages.

hello, I’m having the same issue here. My react app works on localhost but I get a blank page once I upload to netlify
netlify app –
github – GitHub - mo-gbolahan/portfolio

Hey there, @MoG :wave:

Did you try the solution that Luke shared above in this thread: Site is live, but sill blank screen (react app) - #21 by luke let us know if this didn’t work for you.

I am facing the same issue, my site is deployed at
However when I open it a blank screen appears, when I went to the console panel I noticed some errors 404.
Here are the images:

Please remove homepage from your package.json. same problem i’m getting blank screen when opening it
git hub repo-

Hi @kkchad :wave:t6: ,

Did you try this? Site is live, but sill blank screen (react app) - #21 by luke

i did not understand what [luke] is saying :frowning:

@kkchad Your app loads for me, then crashes with the white screen, showing errors in the developer console:

The repository that you’ve linked to is likely set to private and currently shows as a 404.

I am also getting the same problem.

@udit If you want assistance you should create your own thread and provide details for your project.

I’m getting the same problem, please help me fix it.
repo link - GitHub - barbieagrawal/react-portfolio: First update
site link -

@barbieagrawal Your site is referencing files in /react-portfolio/ which isn’t where the files are:

The files aren’t in /react-portfolio/, for example:

Double check what folder your build outputs, your paths, and ensure that your Build configuration is correct.

thank you so much, my site is successfully live now!

i got same problem this my site
and my github repo
please help me fix !!!

@shino80 There may be multiple issues, but the first one I see is code that is broken.


It presumes the user will have a localStorage value which they may not have.

You should debug your code and ensure it works with a fresh session.

thank you very much, I fixed it and it works.