Site deploys but won't update

Hello, I have my site linked up to my git hub account and when I deploy the site it builds and says that it was successful and published but the site doesn’t update? I’ve tried linking it to 2 different repos that both update but it doesn’t show the updates on my site? I am receiving no errors. Any help would be greatly appreciated.

thanks Jerome Caruso

@jerome0caruso Welcome to the Netlify community. Is the site actually not updating or are you seeing the results of local caching?

To circumvent local caching, you could try visiting your site in a new private / incognito window, or viewing in via something like GTMetrix.

To check if the files are updating or not, you could download the deploy and compare the file contents with what you expect to be there.

You might have a few errors

E.g. URL for default.css is on your page, when in reality it is

Thank you I didn’t notice this? This doesn’t happen with the local build. It seems like its changing the directory because it’s pulling from the github repo named Portfolio? Where would I change the directory to? I’ve tried ‘./css/filename.css’ and “%PUBLIC_URL%/css/default.css” and nothing seems to work? The site was working and I change the contact for and how everything broke is beyond me. Thanks

Thank you, I guess it was caching even though I was hitting control-f5, I guess I do have some errors that popped up with finding my css directories but I didn’t change any of that from the working build. Thanks for the tips on seeing the site from a new incognito view. Any tips on fixing the errors messages list below would be awesome. Thanks

The homepage value in your package.json is This is incorrect (and where the /Portfolio/ is generated from no doubt.)

Thank you so much for all your help! I forgot I tried to use the site on git hub pages. Really appreciate it!