Setup email tracking subdomain

Hi Team,

site name:

I am trying to setup a custom tracking domain.
I am following the steps here →

In short, the idea is to create a subdomain from my main site, and create a CNAME that points to “”.

Here are steps to reproduce:

  1. Create a new project / git repo
  2. Create a new site on Netlify as a subdomain and connect it to the newly created git repo (in my case, I chose
  3. Go to DNS settings for new site/subdomain on Netlify.
  4. We get automatically redirected to main site’s DNS settings.
  5. Add in CNAME record that points to

Within 24 hours, the expectation is to be able to confirm setup successful.
One way to test this is to ping, using a tool such as Remote Ping Test / Ping Online • Wormly Monitoring, and ensuring it “pings”

Thank you in advance.

Hey @madleo

I see is using Netlify DNS. If you wish to have a subdomain (e.g. pointing to another service, you add the record for such to Netlify DNS. You would not create a site for this subdomain to point to as it would then not point to the other service.


from what I can see DNS for points to	3413	IN	CNAME

however it loads a Next.js app from Netlify.

1 Like

Ah, that’s very helpful, thank you.
I deleted the ‘subdomain site’ as well as the current CNAME record.
I then re-added the CNAME record as shown in your message above.
Does not appear to be synced/working yet, but I imagine it takes some time to propagate/take effect?

Propagation isn’t immediate though usually happens sooner rather than later.

1 Like

Crossing fingers – appreciate the help!

Hi, @madleo. There are conflicting NETLIFY and NETLIFYv6 type DNS records for this domain here (and this link only works when logged into your team at Netlify):

If you delete the NETLIFY and NETLIFYv6 records the CNAME record will start working. If it does not, delete it and recreate it. If it still doesn’t work, please let us know.

We have a support guide with more information about these record types here:

1 Like

Hey Luke!

Appreciate the follow up.
I did as you said – ended up deleting every record relating to the “link…” subdomain.
And…I believe it worked!
Thank you sir.
I can stop crossing my fingers now.