Support Forums

Setting subdomain in namecheap to netlify

I just bough a domain “iwgx.io” from Namecheap

and I already netlify site that is https://iwgx.netlify.app/

and I want add custom subdomain that is “blog.iwgx.io” for that site (https://iwgx.netlify.app/), without using custom nameserver

since I’m deployed many of my apps in several places (netlify, vercel, render, etc), how to do that?

in other word: how can I just get the CNAME record so I’m able to connect it to namecheap?

The docs have an answer: https://docs.netlify.com/domains-https/custom-domains/configure-external-dns/#configure-a-subdomain

1 Like

Hi, @iwgx. @hrishikesh is correct.

Also, I recommend to start off with the external DNS instructions and make a DNS record like this (meaning, make the record at Namecheap):

blog 1800 IN CNAME  iwgx.netlify.app

Then use the instructions @hrishikesh sent to add the custom domain to the site settings.

If that doesn’t work or if there are other questions, please let us know.

1 Like

thanks, but now the problem is I got no SSL https://blog.iwgx.io/
what should I do now?

in my project domain management I’m already got one

welp, it’ solved now looks like i must wait for a while

Hi, @iwgx. Most often the delay is caused by time to live (TTL) values:

yeah, thanks it’s been solved now

but tbh I don’t like the experience, at least it should show loading spinner (like Vercel does) not show the error, It really make me confused since I don’t know what wrong

Hi, @iwgx, there was no issue at Netlify. The issue was with your local system or resolver.

A remote system won’t be able to detect local DNS caching issue for your system so there is no way for us to show a spinner. SSL was only not working for you because of your local TTL issues.

Sorry, I think we have misunderstanding here, I mean not the loading when “Netlify show it’s been enabled, but I’m still not get https” like I show in my previous comment with the screenshot

I think it will better If I show a video instead sorry

Hi, @iwgx, if you are not getting SSL for a response to that site, we need more information to troubleshoot.

First, if possible, please send us the x-nf-request-id response header which we send with all HTTP responses for the failing HTTP request. There more information about this header here:

If that header isn’t available for any reason (like a failed SSL negotiation), please send the information it replaces (or as many of these details as possible). Those details are:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

We are happy to troubleshoot if you help us to do so by providing this information.