Regression in builds? Builds are successful but deployed version is wrong

I’ve tried with two projects now. Both are built with eleventy and npm and locally they run fine. Just a few days ago, both projects also ran on Netlify just fine.

Since yesterday, both projects are still building successfully on Netlify (according to logs and status) but the deploys are missing most files and the end result is the default Netlify 404 page.


First example: https://11ty-blog-njk-starter.netlify.app

Last commit was a month ago and it autodeploys from Github, it works perfectly. If I fork the project and build it on Netlify, it doesn’t work. https://venerable-tanuki-7e7202.netlify.app is exactly the same version as the site above.

The deploy for the previous site only has the assets folder and a manifest.json, nothing else.

Here’s the code, GitHub - httpsterio/11ty-blog-njk-starter


Second example: https://dashing-ganache-004a2d.netlify.app

Here’s the locally built and manually deployed version: https://mainstream.sh

Commits after this yesterday GitHub - mainstreamsh/mainstream.sh at 58253cb60ae8d7e6038773e39b63a299dfa1f37a started having problems. Reverting to that commit or older is still having the same problem so it feels like something has broken on Netlify’s end.

Ok, update.
https://venerable-tanuki-7e7202.netlify.app after triggering a deploy now works. I did trigger several deploys earlier so there has been some issue on Netlify’s end that has now been resolved.

https://dashing-ganache-004a2d.netlify.app is still not working, The deploy now threw a few errors on some files, failing to upload them. The deployment has also been stuck for 4 minutes now uploading the site to the CDN.

edit. Retriggering a build for dashing-ganache seemed to do the trick. So, apparently there are some intermittent errors on Netlify’s end? Could you please confirm this?

hi there, could you say a bit more about the errors you saw when uploading? what kind of errors are they and what kinds of files are causing them? thanks.

6:47:32 PM: Failed to upload file: assets/img/chevron-left.svg
6:47:39 PM: Failed to upload file: assets/fonts/supply-bold.woff2
6:48:03 PM: Failed to upload file: assets/fonts/supply-medium.woff2
6:48:06 PM: Failed to upload file: assets/fonts/supply-thin.woff2
6:48:09 PM: Failed to upload file: assets/fonts/supply-light.woff2
6:48:09 PM: ​
6:48:09 PM: ────────────────────────────────────────────────────────────────
6:48:09 PM: Configuration error
6:48:09 PM: ────────────────────────────────────────────────────────────────
6:48:09 PM: ​
6:48:09 PM: Error message
6:48:09 PM: Deploy did not succeed: [PUT /deploys/{deploy_id}/files/{path}][422] uploadDeployFile default &{Code:422 Message:No records matched}
6:48:09 PM: ​
6:48:09 PM: Resolved config
6:48:09 PM: build:
6:48:09 PM: command: npm run build
6:48:09 PM: commandOrigin: ui
6:48:09 PM: publish: /opt/build/repo/_site
6:48:09 PM: publishOrigin: ui

This same build worked after triggering a new deploy but only after some 12 hours or so.

hmm, that is very strange.

could you check on netlifystatus.com and see if any of this odd behaviour coincides with issues we were seeing system wide?

My problems began at UTC time midnight on the 16th/17th and carried on until UTC 1PM on the 17th roughly so about 13 hours. The incident on the 15th had been marked as resolved when I checked it during the initial issues and all operations were marked as functional.

I didn’t check any Github issues at the time. Commits, pushes and pulls worked with no issues though and looking at the deploy logs, Netlify did manage to pull all my files and process them as well.