Re-Enable Outgoing Webhook


I have an outgoing webhook configured to call a lambda-function on a “new form submission” event that was recently disabled. I’m running into the following issues that I’m hoping you can assist with:

  1. I’m unable to pull up the corresponding function log to determine the cause of the error. Shouldn’t I be able to? The log never loads, I just get the endless spinner.

  2. I can’t re-enable the hook due to the following error: “A webhook for this event and URL already exists.” I have multiple hooks setup the same way - unique by Event, URL and Form, but now I’m not to re-enable this hook. Please advise.


Hiya @kyeck,

Our function logs only go back an hour in time, so if you haven’t seen any executions in the past hour, you wouldn’t see any logs. I can tell you that we disable hooks that return an HTTP status of >400 6 times in a row, so that happened at some point.

I can see the duplicate hooks in our database targeting the send-form-emails function. I’ve removed the one that is marked disabled, since they were literally identical and that shouldn’t be possible. Please let me know if it is working better now!

Thanks for the response.

I knew the logs don’t go back too far, but the log page wouldn’t finish loading for me (just the spinner was displayed). Tried again this morning and I saw the error from recent submission.

For the webhooks, I modified the function to respond properly (regardless of the form submitted) and removed all but two of the webhooks. However, I’m still not able to re-enable them. The URLs are different. Do the paths need to be different?


Hi @kyeck, the error you show in the screenshot is due to the ‘Event to listen for’ is a type that you already have configured. You’ll want to remove the existing ‘New form submission’ notification before you can create a new one. Let me know if that helps.