Proxy rule not updating to new target

We are experiencing an issue with a forced 200 redirect not updating to a new target URL.

Here is the current redirect rule with the new asset:
/pdf/eoy-report.pdf http://downloads.ctfassets.net/f107dq97zt0a/49DiyqF3MQulqd03TkWhnk/61afd65a53a43b1458e9e90371cf4459/Lime_EOY_Report_2020.pdf 200!

However, going to that URL loads an old asset (under Table of Contents, “Safety” is marked as page 64 in the old asset):
https://www.li.me/pdf/eoy-report.pdf

While it is marked as page 62 in the new asset:

The same rule works correctly in our branch deployment, which I cannot share as it is behind authentication.

Is this an issue with the old proxy rule being cached on Netlify’s end? We’ve tried rebuilding the site with a cleared cache with no luck.

For reference, here is a request ID that fails to load the proper asset:
x-nf-request-id: ee38f799-7bcc-471e-83d5-4a4f844045f5-1953658

Here is one from the branch deployment that loads the correct asset using the same redirect rule:
x-nf-request-id: fd171cd1-411b-4311-a2da-b1683ea18b82-277321

Hi, @mabfine. I’m seeing the following cache control header returned:

cache-control: max-age=2592000

This header is causing our service to cache the proxied resource up to 30 days. You can override this caching with a s-maxage cache control option which overrides the max-age option’s caching for proxies.

If there are other questions about this, please let us know.