Home
Support Forums

Problems rendering recharts on Netlify

Netlify site: https://alisson-rodrigues-es.netlify.app/
My code: https://replit.com/@AlissonRodrigu3/Website-en-Espanol
Github repository: GitHub - ar-rodrigues/Website-en-Espanol: Sitio web personal en español

Hello! I’m having problems rendering Recharts on Netlify. I wrote my code on replit, and they use Vite to work with React.
My problem is in the component Skills, with PolarGrid, PolarAngleAxis and PolarRadiusAxis. On Replit they render normally, but when I deploy on Netlify it does work, it crushes the page.

I don’t receive any log .

Hi @ar-rodrigues,

According to the browser dev tools’ console, there seems to be something highly wrong with the code as it just throws a lot of errors and crashes the page.

I don’t see a way to be able to download the code from Replit. I’d prefer to test this in my local IDE - do you have a copy that I can download?

Hi @ar-rodrigues

I can’t get the code on Replit to run. I just see Repl Waking up…

So I copied/pasted the code and deployed to Netlify. On the deployed page, the Skills components works properly (I assume.)

Yes!! Sorry, I forgot to put the Github repository on my post.
Here is the repository: GitHub - ar-rodrigues/Website-en-Espanol: Sitio web personal en español

I will update the post to have the github link.

Did you change anything?? I tried to deploy to Netifly yesteday and the Skills kept broking the whole code hahaha
I deployed the code to netlify by the repository on github, you uploaded the code directly?
Can you send me the netlify link page?

No, but yes.

The copy/pasted code (minus images) is coelmay/replit-alisson deployed thirsty-golick-a11dcf.

Just to check I forked your repository coelmay/Website-en-Espanol and deployed here with the same result as you.
I then deleted the package-lock.json from the repository and redeployed here and it works (as my original deploy did.)

The npm WARN old lockfile in the deploy log from the first deploy of the forked repository hinted at that file being the possible issue/cause.

1 Like

Yeeeeeahh!!! It worked!!

I just deleted the package-lock.json and redeployed to Netlify the repository and it worked nicely!!

Thank you so much!! I didn’t had any clue hahah :grin:

1 Like