Home
Support Forums

Problem with: 'Reading and parsing configuration files'

Hello dear support command, I’m really sorry that I’ve made this issue, because in there are the same 2 topics. But I cannot deploy my site after introducing webpack in my app.

I’ve read the 2 topics, but It doesn’t work for me, please, help me.

Site name: earnenglishwords.netlify.app
The build log:

The problem happens on first line, where I use “import ‘./style.css’”
Could you help please?

P.S. I can’t put in here my another images because I’m new user in here, but, I think it will help. So ask me for more details there Sr233@yandex.ru

Thank you for your time.

I deployed your site using Netlify Drop. This appears in the console.

Uncaught SyntaxError: Cannot use import statement outside a module

because you have import "./style.css" in your index.js. Remove the import and add <link rel="stylesheet" type="text/css" href="style.css"/> to into the <head> ... </head> of your index.html.

Also, consider making your video smaller, converting it to webm, or using a service such as Cloudinary to host the video or use Netlify LFS.

1 Like

I’ve changed as you said, but it still doesn’t work.
I’ve tried to fix that within redeploying, but it didn’t help too.

And yes, I used Netlify Drop, it works there. So a problem might be in Netlify?

I have deployed your site at https://stoic-panini-2296fb.netlify.app using drag and drop (deploy log here.)

I then pushed it to GitHub, linked it and it is available as a deploy preview at https://60e9452e6f32a8bbd68c0676–stoic-panini-2296fb.netlify.app (deploy log here.)

In both cases though, I removed the video.

Note: there is not need for the package.json, package-lock.json or webpack.config.js files as there is nothing to build as is evidenced by the deploy preview I made after removing aforementioned files https://60e946749c263100081c8b58–stoic-panini-2296fb.netlify.app (deploy log here.)

Repository: https://github.com/coelmay/LearnNewWordsEasier-master-1

There’s a simple fix to the problem. The logs say, base directory doesn’t exist.

Your base directory is set as dist:

It should probably be your publish directory.