Problem with custom domain and SSL/TLS certificate

About three days ago I have set up a custom domain, but I still get “Address Not Found” if i try to visit the url from mobile. Settings of the DNS looks ok but I still get an error “We could not provision a Let’s Encrypt certificate for your custom domain”.

My Netlify site name is and is my custom domain already owned and buyed on porkbun provider.

Please help me, with understanding or fixing the issue.
Thank you for your support

@donnie has it been 48 hours since you configured your dns. If it has not you’ll need to wait to see if propagation sorts the issue out.

It seems that your domain have DNSSEC enabled at one point at that the DNSSEC’s DS record is still live on the registry level.

You will need to disable that on Porkbun. Netlify DNS does not support DNSSEC at the moment.

It may take another 24 hours or so before the changes get propagated.

1 Like

Nice, I have deleted the existent DNSSEC record from porkbun domain settings.
I hope deleting that record means disabling it because I can’t still find any option for disabling it on porkbun settings.
Let’s wait for the changes propagating and thank you for your help!

Hi @donnie,

Looks like propagation has completed, I was able to get the SSL Certificate for the site. You can view it here: Netlify App

Hope this helps!