Problem of 404 when using "getServerSideProps"


I’m using “getServerSideProps” for a page and I get a 404 error on it. I’ve seen on this page that I need to set target: "serverless". Unfortunatelly, I have to put target: 'experimental-serverless-trace' because I have i18n-next (Issue “solved” here: Build with next-i18next error: Error: Cannot find module './next-i18next.config.js' - #3 by jguix)…

Do you think that it can be that? When I build+start on my machine, everything is working.

Thank you,

FYI, it works on Vercel.

First it fails because of an error in the generated function: Error: ENOENT: no such file or directory, scandir '/var/task/public/locales/en'

But then I found the fix.

Then it worked on Vercel, but not on Netlify :frowning: I just have my 404 error and have no logs anywhere. Is there any logs available somewhere for the code that is executed in “getServerSideProps” ? I see no “function” in my dashboard, so I’m a bit lost.

Thank you,

hi there, this sounds frustrating!

I would suggest that the next best step (pardon the pun) is to file an issue here so that the next folks can take a look: