Problem building PR - ENOENT errors on npm install

I have a problem deploying this PR:

I tried to set up eleventy-netlify-boilerplate

And as far as I can tell my settings are the exact same, my build command is “eleventy” and publish dir is “_site” just like the boilerplate

But somehow it seems that npm install fails with a lot of ENOENT errors.

11:30:30 AM: Installing NPM modules using NPM version 6.14.4

11:30:35 AM: npm WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/lodash-1754cffb/LICENSE'

11:30:35 AM: npm WARN tar ENOENT: no such file or directory, open '/opt/build/repo/node_modules/.staging/lint-staged-d40f0b28/lib/makeCmdTasks.js'

I hope you can help?

hi, does this error still occur after clearing the deploy cache and redeploying?

I can’t log in online. There is no box to log in with my netlify account - it’s simply missing. So I’ll try and reply her on email.

Yes the error kept happening even when clearing the cache etc.

In the end I moved all the dependencies not needed for netlify build to devDependencies and setting NODE_ENV=“production” on Netlify, and that solved the problem. I still don’t know why nvm install was failing before…

howdy ebdrup - am i understanding correctly that you’re unable to log in to netlify? we’d love to understand why so we can fix it! a screenshot or more details on what is happening would be super helpful! Or are you having problems logging into the forums? again, we’d love to understand what’s not working so we can make it better.

It was on the forums. When I clicked reply. The place where it says “click below to log in with netlify” there was nothing - no button or anything. Also the layout seems to have a lot of flaws.
I’m on latest Chrome on fully updated osx catalina

Allan Ebdrup

hey allan, sorry to hear that. Are you able to send us a screenshot of what you are seeing?

and just to rule this out, are you using any browser extensions (such as adblockers) that might change the behaviour of the page?

Actually I am now logged in I think I went to the main page and logged in) I don’t dare log out again…

Great - I am definitely glad you were able to log in. Do you have any more details on how you got this working so I can investigate more and make sure this doesn’t happen for other people?

At the moment I can’t narrow it down, unfortunately, as yours is the only report for these kinds of issues (not saying I don’t believe you, but it may be something hard to find that is causing this behaviour)

as much additional information as you have would be helpful!

I would just wait and see if someone else reports it too. I. Write anothe ticket if it happens again. With screenshots

Allan Ebdrup

1 Like