Page Not Found on deploy- Git Hub

I’m new to development and part of one of the projects I’m working on has me signing up for deploying my git. I’m using the hugo-academic template I found on git.
Page Not Found Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.” once I’ve clicked on the link provided by netlify. I’ve tried everything and it didn’t work…


@legey Welcome to the Netlify community.

Have you consulted this information yet?

Thanks Gregraven.

Yes I consulted and it didn’t work…

howdy, can you show us a screenshot of your build settings please?

@legey I was going to suggest downloading a copy of your deploy to make certain that each of your files is where you (and Netlify) expect it to be.

1 Like

that’s a great idea, greg.

I tried again, and now it’s giving error :frowning:

6:51:34 PM: Build ready to start

6:51:36 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6

6:51:36 PM: build-image tag: v3.4.1

6:51:36 PM: buildbot version: fcbc7a79f7372e5995cf02954ef19fc48d20c871

6:51:36 PM: Fetching cached dependencies

6:51:36 PM: Starting to download cache of 8.8MB

6:51:36 PM: Finished downloading cache in 317.922244ms

6:51:36 PM: Starting to extract cache

6:51:36 PM: Finished extracting cache in 126.958995ms

6:51:36 PM: Finished fetching cache in 448.624352ms

6:51:36 PM: Starting to prepare the repo for build

6:51:37 PM: Preparing Git Reference refs/heads/master

6:51:38 PM: Failing build: Failed to parse configuration

6:51:38 PM: Failed during stage ‘Reading and parsing configuration files’:
Base directory does not exist: /opt/build/repo/exampleSite

: exit status 1

6:51:39 PM: Finished processing build request in 3.106201006s

@legey Make sure to have any ad blockers or tracking plugins turned off for

Yes, I had already tested this

hi legey, looking at your package.json, i think you have quite a few things (dependencies and also commands) missing that are needed to build your project.

I only see this in your package.json:

  "devDependencies": {},
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"

which isn’t really enough. What commands are you running to build this app locally?

see this thread i responded to in depth today that contains a lot more info:

and this might be helpful too: