NuxtJS deploy/building failing

Hello. Im trying to deploy my NuxtJS website but it keeps failing, no matter what i try. I hope someone can help me! also i hope i gave enough info!

Website URL:

There is some info:

Build command: npm run generate
Publish directory: dist

Build command: npm run build
Publish directory: dist

hey there, looks like you are trying to output the generated files into a directory called dist, but that directory doesn’t exist.

a.) is this the for sure right directory you want to use?
b.) what happens if you create a directory with that name and add it to your GH repo, does your build succeed in that case?
c.) here is some generic debugging informaiton that might help:

let us know what happens!

1 Like

i tried this method, it published it put it still shows the 404 page. i used npm run build and dist

ah! a 404 page means something else though - your deploy succeeded? Thats a different problem ( a better one)

This guide might help:

Hello, i used this tutorial :smiley: i had to put nuxt build && nuxt export to the build command to get it working, earlier i somehow didnt care about that. But it works now! Without your method earlier, i would still be stuck :joy:

1 Like

well i am definitely glad its’ working now! congrats. :slight_smile:

1 Like

Hey guys (cc: @perry), the build logs are not showing the individual Nuxt routes being generated (and not even the details about the Client/Server or the chunks processing):


Any way to force the build on Netlify to display the full details?


Complementing the post above, this is how I see it when running the build locally on my machine:


I believe that the logs in the buildbot is less verbose due to having CI=true set by default. You could add an env var in the UI for CI=false and see if that gets you the more verbose logs.

1 Like

Additionally, please don’t hesitate to start a new topic if your issue or question is not specifically related to an existing topic (like this one). Thanks!