Home
Support Forums

Nuxt Generate Failing in Deployment

I am attempting to deploy a nuxt site and have deployed it at least twice before. However, after updating a few items builds are failing in netfliy but succeeding locally.

Last thing changed in the repo, outside some html, was the addition of sass, sass-loader@10, and fibers. After reverting these changes the site deploys fine.

Local version of Node is 15.0.1 and npm is 7.0.3.

Update:

Changed the build version of Node to match local and it is deploying correctly.

Error:

2:32:17 PM: $ npm run generate
2:32:17 PM: > marketing@1.0.0 generate
2:32:17 PM: > nuxt generate
2:32:25 PM: node: ../src/coroutine.cc:134: void* find_thread_id_key(void*): Assertion `thread_id_key != 0x7777' failed.
Aborted

package.json:

{
  "name": "marketing",
  "version": "1.0.0",
  "private": true,
  "scripts": {
    "dev": "nuxt",
    "build": "nuxt build",
    "start": "nuxt start",
    "generate": "nuxt generate",
    "lint:js": "eslint --ext \".js,.vue\" --ignore-path .gitignore .",
    "lint": "npm run lint:js"
  },
  "dependencies": {
    "core-js": "^3.15.1",
    "nuxt": "^2.15.7"
  },
  "devDependencies": {
    "@babel/eslint-parser": "^7.14.7",
    "@nuxtjs/eslint-config": "^6.0.1",
    "@nuxtjs/eslint-module": "^3.0.2",
    "@nuxtjs/tailwindcss": "^4.2.0",
    "eslint": "^7.29.0",
    "eslint-config-prettier": "^8.3.0",
    "eslint-plugin-nuxt": "^2.0.0",
    "eslint-plugin-vue": "^7.12.1",
    "fibers": "^5.0.0", // Removed to get deploy to work
    "postcss": "^8.3.5",
    "prettier": "^2.3.2",
    "sass": "^1.42.1",  // Removed to get deploy to work
    "sass-loader": "^10.2.0"  // Removed to get deploy to work
  }
}

So you fixed it?
What was the problem?

I had a similar issue with Nuxt. I just had to update both node and npm to the latest and it worked.

Hi @wildbeard

Thanks for coming back with an update on how you solved this for yourself. This information may assist others in the future.

1 Like

It ended up being a node version mismatch.

I could dig into it further but I think it is either sass or sass-loader on node v16. I tried uninstalling fibers and it didn’t work so went ahead and rolled back the addition of sass and sass-loader and it deployed. Added all three back and set NODE_VERSION to 15.0.1 and it deployed successfully.

1 Like