Nuxt 3.8.2 referring to the different file hashing, cache issue?

When I run the site locally everything works fine but when I deploy the site to my dist folder the site won’t work:

Screenshot 2023-12-05 at 8.14.08 am

in the deployment sections, the build files are visible with different suffixes:

what is going on?

Hiya, can you share the site experiencing this?

The live site now is out of previous release, I reverted back but you can access the new faulty release here View Site.


@SamO any thoughts? I tried to re-deploy and clear cache but the issue is still present.

Ok, after further investigation. The site us using the old version of the index.html which is referring to the old _nuxt folder/files. When I download the index.html from the file browser the HTML reference is a correct one. What to do now? Cleared the browser cache & post deployment cache…

Let me know if you need anything else from me, link and more info posted above? Thanks

@fool @luke guys are you able to look into this please. It looks like this is a similar issue I have helped before? It is my second day trying to work this out and I’m a bit out of ideas here. Thanks

CC: @fool @luke

I tried already:

  • Changing Publish directory from dist to build and reflect this in my nuxt.config.ts
  • Clear cache and retry with latest branch commit
  • Try multiple deploys with a different small settings
  • Manipulating index meta so it forces refresh

The issue must be on the Netlify side as is present on the main domain as well as permalink.

Any new deploy still refers to the old index.html from Dec 1 at 10:35 AM Production: master@[dd95da7]

To test see here: Preview the Issue

You seem to be using manual deploys, so I’m assuming it’s the CLI. Are you running netlify deploy --build?