Not able to deploy site on Netlify "build.command" failed

Hello I am not able to deploye my site on Netlify called Netlify App

I have read some of your forums and tried to do changes in my netlify.toml but without success. Right now my netlify.toml looks like this:
base = “code/”
publish = “build/”
command = “CI= npm run build”

and this is the error I am given on Netlify “build.command” failed .
My deployment settings are following:
Base directory
Not set

Build command
CI= npm run build

Publish directory

Deploy log visibility
Logs are public


The site works perfectly when checking via npm start in my terminal.

Hi @Soederstroem1612

Can you share the build log please?

1 Like

Hello @coelmay,

Thank you for getting back to me! :slight_smile: The build log:
Line 4:1: Definition for rule ‘import/no-cycle’ was not found import/no-cycle

was not happy with the way I imported my components App.js into the index.js. I forgot to use curly braces here import { App } from ‘./App’; so I fixed it manually and now it is working. Sorry for late reply :slight_smile:

Thanks for coming back and sharing the solution! Glad you got this working :rocket: