New DNS CNAME records active by dig but inaccessible via browser

I have the CNAME record which was totally working before.

I had to delete it and create a new one because the target IP changed. But now that and other new CNAME records I add do not work in the browser.

I checked the api subdomain using dig I can see that it is active and pointing to the correct IP but when I try to open it on the browser it times out.

The target IP is totally accesible, the problem seems to be the DNS for some reason.

CNAME (Canonical Name) record is an alias for another canonical name record.

Change the CNAME record to an A record.

Tried using an A with pointing to a public IP but it is not working either.

dig returns the correct record but browser still times out.

Tried it with a new CNAME pointing to another domain but it does not work either.

That same subdomain used to point to an AWS domain name with no problem. Today I tried to redirect to a new domain but it started failing.

It isn’t timing out for me.

Yeah, I can access now. I guess it was an issue with my browsers cache. Thanks for the help!